]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/integration.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / integration.nix
diff --git a/modules/private/websites/piedsjaloux/integration.nix b/modules/private/websites/piedsjaloux/integration.nix
deleted file mode 100644 (file)
index 3502964..0000000
+++ /dev/null
@@ -1,135 +0,0 @@
-{ lib, pkgs, config,  ... }:
-let
-  secrets = config.myEnv.websites.piedsjaloux.integration;
-  webRoot = "/var/lib/ftp/immae/piedsjaloux/web";
-  cfg = config.myServices.websites.piedsjaloux.integration;
-  pcfg = config.services.phpApplication;
-  texlive = pkgs.texlive.combine { inherit (pkgs.texlive) attachfile preprint scheme-small; };
-in {
-  options.myServices.websites.piedsjaloux.integration.enable = lib.mkEnableOption "enable PiedsJaloux's website in integration";
-
-  config = lib.mkIf cfg.enable {
-    services.phpApplication.apps.piedsjaloux_integration = {
-      websiteEnv = "integration";
-      httpdUser = config.services.httpd.Inte.user;
-      httpdGroup = config.services.httpd.Inte.group;
-      inherit webRoot;
-      varDir = "/var/lib/ftp/immae/piedsjaloux_var";
-      varDirPaths = {
-        "tmp" = "0700";
-      };
-      app = "/var/lib/ftp/immae/piedsjaloux";
-      serviceDeps = [ "mysql.service" ];
-      preStartActions = [
-        "./bin/console --env=dev cache:clear --no-warmup"
-      ];
-      phpOpenbasedir = [ "/tmp" ];
-      phpPool = {
-        "php_admin_value[upload_max_filesize]" = "20M";
-        "php_admin_value[post_max_size]" = "20M";
-        #"php_admin_flag[log_errors]" = "on";
-        "pm" = "ondemand";
-        "pm.max_children" = "5";
-        "pm.process_idle_timeout" = "60";
-      };
-      phpEnv = {
-        PATH = lib.makeBinPath [
-          pkgs.apg pkgs.unzip
-          # below ones don't need to be in the PATH but they’re used in
-          # secrets
-          pkgs.imagemagick texlive
-        ];
-        SYMFONY_DEBUG_MODE = "\"yes\"";
-      };
-      phpWatchFiles = [
-        config.secrets.fullPaths."websites/piedsjaloux/integration"
-      ];
-      phpPackage = pkgs.php72;
-    };
-
-    secrets.keys."websites/piedsjaloux/integration" = {
-      user = config.services.httpd.Inte.user;
-      group = config.services.httpd.Inte.group;
-      permissions = "0400";
-      text = ''
-        # This file is auto-generated during the composer install
-        parameters:
-            database_host: ${secrets.mysql.host}
-            database_port: ${secrets.mysql.port}
-            database_name: ${secrets.mysql.database}
-            database_user: ${secrets.mysql.user}
-            database_password: ${secrets.mysql.password}
-            database_server_version: ${pkgs.mariadb.mysqlVersion}
-            mailer_transport: smtp
-            mailer_host: 127.0.0.1
-            mailer_user: null
-            mailer_password: null
-            secret: ${secrets.secret}
-            pdflatex: "${texlive}/bin/pdflatex"
-        leapt_im:
-            binary_path: ${pkgs.imagemagick}/bin
-      '';
-    };
-
-    services.websites.env.integration.vhostConfs.piedsjaloux_integration = {
-      certName     = "integration";
-      addToCerts  = true;
-      hosts       = [ "test.pj.immae.dev" ];
-      root        = webRoot;
-      extraConfig = [
-        ''
-        <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.piedsjaloux_integration}|fcgi://localhost"
-        </FilesMatch>
-
-        <Location />
-          Use LDAPConnect
-          Require ldap-group   cn=pj.immae.dev,cn=httpd,ou=services,dc=immae,dc=eu
-          ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://piedsjaloux.fr\"></html>"
-        </Location>
-
-        <Directory ${webRoot}>
-          Options Indexes FollowSymLinks MultiViews Includes
-          AllowOverride None
-          Require all granted
-
-          DirectoryIndex app_dev.php
-
-          <IfModule mod_negotiation.c>
-          Options -MultiViews
-          </IfModule>
-
-          <IfModule mod_rewrite.c>
-            RewriteEngine On
-
-            RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
-            RewriteRule ^(.*) - [E=BASE:%1]
-
-            # Maintenance script
-            RewriteCond %{DOCUMENT_ROOT}/maintenance.php -f
-            RewriteCond %{SCRIPT_FILENAME} !maintenance.php
-            RewriteRule ^.*$ %{ENV:BASE}/maintenance.php [R=503,L]
-            ErrorDocument 503 /maintenance.php
-
-            # Sets the HTTP_AUTHORIZATION header removed by Apache
-            RewriteCond %{HTTP:Authorization} .
-            RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
-
-            RewriteCond %{ENV:REDIRECT_STATUS} ^$
-            RewriteRule ^app_dev\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
-
-            # If the requested filename exists, simply serve it.
-            # We only want to let Apache serve files and not directories.
-            RewriteCond %{REQUEST_FILENAME} -f
-            RewriteRule ^ - [L]
-
-            # Rewrite all other queries to the front controller.
-            RewriteRule ^ %{ENV:BASE}/app_dev.php [L]
-          </IfModule>
-
-        </Directory>
-        ''
-      ];
-    };
-  };
-}