]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/app/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / app / default.nix
diff --git a/modules/private/websites/piedsjaloux/app/default.nix b/modules/private/websites/piedsjaloux/app/default.nix
deleted file mode 100644 (file)
index 4525a18..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-{ environment, varDir, secretsPath
-, composerEnv, fetchurl, fetchgit, sources }:
-let
-  app = composerEnv.buildPackage (
-    import ./php-packages.nix { inherit composerEnv fetchurl fetchgit; } //
-    rec {
-      version = sources.websites-piedsjaloux-app.version;
-      pname = "piedsjaloux";
-      name = "${pname}-${version}";
-      src = sources.websites-piedsjaloux-app;
-      noDev = (environment == "prod");
-      preInstall = ''
-        export SYMFONY_ENV="${environment}"
-        '';
-      # /!\ miniatures and data need to be in the same physical dir due to a
-      #     bug in leapt.im (searches for data/../miniatures)
-      postInstall = ''
-        cd $out
-        rm app/config/parameters.yml
-        ln -sf ${secretsPath} app/config/parameters.yml
-        rm -rf var/{logs,cache,data,miniatures,tmp}
-        ln -sf ${varDir}/{logs,cache,data,miniatures,tmp} var/
-        '';
-        passthru = {
-          inherit varDir environment secretsPath;
-          webRoot = "${app}/web";
-      };
-    });
-in app