]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/papa/maison_bbc.nix
Remove webappdirs
[perso/Immae/Config/Nix.git] / modules / private / websites / papa / maison_bbc.nix
index 528c83209bb94df0df82729bb1f086202fceb792..3eb736ee1b80b515f77a213a7ff7aa3aa70c726f 100644 (file)
@@ -1,23 +1,21 @@
 { lib, config, ... }:
 let
   cfg = config.myServices.websites.papa.maison_bbc;
-  webappdirs = config.services.websites.webappDirsPaths;
 in {
   options.myServices.websites.papa.maison_bbc.enable = lib.mkEnableOption "enable Papa Maison bbc website";
 
   config = lib.mkIf cfg.enable {
     services.webstats.sites = [ { name = "maison.bbc.bouya.org"; } ];
 
-    services.websites.webappDirs.papa_maison_bbc = ./maison_bbc_static;
     services.websites.env.production.vhostConfs.papa_maison_bbc = {
       certName     = "papa";
       addToCerts   = true;
       hosts        = [ "maison.bbc.bouya.org" ];
-      root         = webappdirs.papa_maison_bbc;
+      root         = ./maison_bbc_static;
       extraConfig  = [
         ''
         ErrorDocument 404 /index.html
-        <Directory ${webappdirs.papa_maison_bbc}>
+        <Directory ${./maison_bbc_static}>
           DirectoryIndex index.htm index.html
           AllowOverride None
           Require all granted