]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/naturaloutil/production.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / websites / naturaloutil / production.nix
index 93940d5efc2a35d5921a38ff9e7c8424ce989537..628e1291668a3c915d62710b3d6740cef2a9bf75 100644 (file)
@@ -1,9 +1,9 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   adminer = pkgs.callPackage ../commons/adminer.nix {};
   cfg = config.myServices.websites.naturaloutil.production;
   varDir = "/var/lib/ftp/jerome";
-  env = myconfig.env.websites.jerome;
+  env = config.myEnv.websites.jerome;
 in {
   options.myServices.websites.naturaloutil.production.enable = lib.mkEnableOption "enable Naturaloutil's website";
 
@@ -21,7 +21,7 @@ in {
         <?php
         $mysql_user = '${env.mysql.user}' ;
         $mysql_server = '${env.mysql.host}' ;
-        $mysql_base = '${env.mysql.name}' ;
+        $mysql_base = '${env.mysql.database}' ;
         $mysql_password = '${env.mysql.password}' ;
         //connect to db
         $db = mysqli_init();