]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/naturaloutil/production.nix
Move personal websites to modules
[perso/Immae/Config/Nix.git] / modules / private / websites / naturaloutil / production.nix
similarity index 88%
rename from nixops/modules/websites/ftp/jerome.nix
rename to modules/private/websites/naturaloutil/production.nix
index d00c42dd7bf26461791893fba4e0788bfb92d234..b6cf06912cce1b5ff4a9dcba02b55ec087d41760 100644 (file)
@@ -1,17 +1,13 @@
 { lib, pkgs, config, myconfig,  ... }:
 let
-    adminer = pkgs.callPackage ../commons/adminer.nix {};
-    cfg = config.services.myWebsites.Jerome;
-    varDir = "/var/lib/ftp/jerome";
-    env = myconfig.env.websites.jerome;
+  adminer = pkgs.callPackage ../commons/adminer.nix {};
+  cfg = config.myServices.websites.naturaloutil.production;
+  varDir = "/var/lib/ftp/jerome";
+  env = myconfig.env.websites.jerome;
 in {
-  options.services.myWebsites.Jerome = {
-    production = {
-      enable = lib.mkEnableOption "enable Jerome's website";
-    };
-  };
+  options.myServices.websites.naturaloutil.production.enable = lib.mkEnableOption "enable Naturaloutil's website";
 
-  config = lib.mkIf cfg.production.enable {
+  config = lib.mkIf cfg.enable {
     services.webstats.sites = [ { name = "naturaloutil.immae.eu"; } ];
 
     security.acme.certs."ftp".extraDomains."naturaloutil.immae.eu" = null;