]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/nath/villon.nix
Change Nath’s name
[perso/Immae/Config/Nix.git] / modules / private / websites / nath / villon.nix
similarity index 68%
rename from modules/private/websites/nathanael/villon.nix
rename to modules/private/websites/nath/villon.nix
index 7482de1167ef691ee6d870d0a932a447cf03352d..57a1df574162d364535e013fd2e0fc804851e3ef 100644 (file)
@@ -1,18 +1,18 @@
 { lib, pkgs, config,  ... }:
 let
-  cfg = config.myServices.websites.nathanael.villon;
-  varDir = "/var/lib/ftp/nathanael";
-  env = config.myEnv.websites.nathanael;
+  cfg = config.myServices.websites.nath.villon;
+  varDir = "/var/lib/ftp/nath";
+  env = config.myEnv.websites.nath;
   domain = "sntvillon.immae.eu";
   apacheUser = config.services.httpd.Prod.user;
   apacheGroup = config.services.httpd.Prod.group;
 in {
-  options.myServices.websites.nathanael.villon.enable = lib.mkEnableOption "enable Nathanael's website";
+  options.myServices.websites.nath.villon.enable = lib.mkEnableOption "enable Nath's website";
 
   config = lib.mkIf cfg.enable {
     services.webstats.sites = [ { name = domain; } ];
 
-    system.activationScripts.nathanael_villon = {
+    system.activationScripts.nath_villon = {
       deps = [ "users" ];
       text = ''
         install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d ${varDir}
@@ -20,8 +20,8 @@ in {
     };
     security.acme.certs."ftp".extraDomains."${domain}" = null;
 
-    services.websites.env.production.vhostConfs.nathanael_villon = {
-      certName     = "nathanael";
+    services.websites.env.production.vhostConfs.nath_villon = {
+      certName     = "nath";
       certMainHost = domain;
       hosts        = [ domain ];
       root         = varDir;