]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/ludivinecassal/integration.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / ludivinecassal / integration.nix
index d6459b0e2c7662ce20ac61b47974c3348d059548..d304fdf9e76b390cdc76561b0535079b22a6103c 100644 (file)
@@ -23,15 +23,17 @@ in {
         "./bin/console --env=${app.environment} cache:clear --no-warmup"
       ];
       phpOpenbasedir = [ "/tmp" ];
-      phpPool = ''
-        php_admin_value[upload_max_filesize] = 20M
-        php_admin_value[post_max_size] = 20M
-        ;php_admin_flag[log_errors] = on
-        pm = ondemand
-        pm.max_children = 5
-        pm.process_idle_timeout = 60
-        env[SYMFONY_DEBUG_MODE] = "yes"
-      '';
+      phpPool = {
+        "php_admin_value[upload_max_filesize]" = "20M";
+        "php_admin_value[post_max_size]" = "20M";
+        #"php_admin_flag[log_errors]" = "on";
+        "pm" = "ondemand";
+        "pm.max_children" = "5";
+        "pm.process_idle_timeout" = "60";
+      };
+      phpEnv = {
+        SYMFONY_DEBUG_MODE = "yes";
+      };
       phpWatchFiles = [
         config.secrets.fullPaths."webapps/${app.environment}-ludivinecassal"
       ];
@@ -77,7 +79,7 @@ in {
     ];
 
     services.websites.env.integration.vhostConfs.ludivinecassal_dev = {
-      certName     = "eldiron";
+      certName     = "integration";
       addToCerts  = true;
       hosts       = [ "ludivine.immae.eu" ];
       root        = pcfg.webappDirs.ludivinecassal_dev;