]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/ludivine/app/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / modules / private / websites / ludivine / app / default.nix
diff --git a/modules/private/websites/ludivine/app/default.nix b/modules/private/websites/ludivine/app/default.nix
deleted file mode 100644 (file)
index 323b6e0..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-{ environment, varDir, secretsPath
-, composerEnv, fetchurl, fetchgit, imagemagick, sass, ruby, sources }:
-let
-  app = composerEnv.buildPackage (
-    import ./php-packages.nix { inherit composerEnv fetchurl fetchgit; } //
-    rec {
-      name = "${pname}-${version}";
-      pname = "ludivinecassal";
-      version = sources.websites-ludivine-app.version;
-      src = sources.websites-ludivine-app;
-      noDev = (environment == "prod");
-      preInstall = ''
-        export SYMFONY_ENV="${environment}"
-        cp app/config/parameters.yml.dist app/config/parameters.yml
-        cat >> app/config/parameters.yml <<EOF
-        leapt_im:
-            binary_path: ${imagemagick}/bin
-        assetic:
-            sass: ${sass}/bin/sass
-            ruby: ${ruby}/bin/ruby
-        EOF
-        sed -i -e "/Incenteev..ParameterHandler..ScriptHandler::buildParameters/d" composer.json
-        '';
-      # /!\ miniatures and data need to be in the same physical dir due to a
-      #     bug in leapt.im (searches for data/../miniatures)
-      postInstall = ''
-        rm -rf var/{logs,cache,data,miniatures,tmp}
-        ln -sf ${varDir}/{logs,cache,data,miniatures,tmp} var/
-        ln -sf ${secretsPath} app/config/parameters.yml
-        '';
-      buildInputs = [ sass ];
-      passthru = {
-        inherit varDir environment;
-        webRoot = "${app}/web";
-      };
-    });
-in app