]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/isabelle/aten_integration.nix
Refactor websites
[perso/Immae/Config/Nix.git] / modules / private / websites / isabelle / aten_integration.nix
index fb6eda977c7a2b881cace05b1084f646dd24efbf..61c35cc42fa6fec14bfbd6ae05fc5d4e9187dade 100644 (file)
@@ -1,20 +1,23 @@
 { lib, pkgs, config,  ... }:
 let
   secrets = config.myEnv.websites.isabelle.aten_integration;
-  app = pkgs.webapps.aten.override { environment = secrets.environment; };
+  app = pkgs.callPackage ./aten_app {
+    environment = secrets.environment;
+    varDir = "/var/lib/isabelle_aten_integration";
+  };
   cfg = config.myServices.websites.isabelle.aten_integration;
   pcfg = config.services.phpApplication;
 in {
   options.myServices.websites.isabelle.aten_integration.enable = lib.mkEnableOption "enable Aten's website in integration";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.aten_dev.rootDir = app.varDir;
-    services.phpApplication.apps.aten_dev = {
+    services.duplyBackup.profiles.isabelle_aten_integration.rootDir = app.varDir;
+    services.phpApplication.apps.isabelle_aten_integration = {
       websiteEnv = "integration";
       httpdUser = config.services.httpd.Inte.user;
       httpdGroup = config.services.httpd.Inte.group;
       httpdWatchFiles = [
-        config.secrets.fullPaths."webapps/${app.environment}-aten"
+        config.secrets.fullPaths."websites/isabelle/aten_integration"
       ];
       inherit (app) webRoot varDir;
       inherit app;
@@ -32,12 +35,12 @@ in {
         "pm.process_idle_timeout" = "60";
       };
       phpEnv = {
-        SYMFONY_DEBUG_MODE = "yes";
+        SYMFONY_DEBUG_MODE = "\"yes\"";
       };
     };
 
     secrets.keys = [{
-      dest = "webapps/${app.environment}-aten";
+      dest = "websites/isabelle/aten_integration";
       user = config.services.httpd.Inte.user;
       group = config.services.httpd.Inte.group;
       permissions = "0400";
@@ -52,18 +55,18 @@ in {
         SetEnv DATABASE_URL "${psql_url}"
         '';
     }];
-    services.websites.env.integration.vhostConfs.aten_dev = {
+    services.websites.env.integration.vhostConfs.isabelle_aten_integration = {
       certName    = "integration";
       addToCerts  = true;
       hosts       = [ "dev.aten.pro" ];
-      root        = pcfg.webappDirs.aten_dev;
+      root        = pcfg.webappDirs.isabelle_aten_integration;
       extraConfig = [
         ''
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.aten_dev}|fcgi://localhost"
+          SetHandler "proxy:unix:${pcfg.phpListenPaths.isabelle_aten_integration}|fcgi://localhost"
         </FilesMatch>
 
-        Include ${config.secrets.fullPaths."webapps/${app.environment}-aten"}
+        Include ${config.secrets.fullPaths."websites/isabelle/aten_integration"}
 
         <Location />
           Use LDAPConnect
@@ -77,7 +80,7 @@ in {
           ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://aten.pro\"></html>"
         </Location>
 
-        <Directory ${pcfg.webappDirs.aten_dev}>
+        <Directory ${pcfg.webappDirs.isabelle_aten_integration}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted