]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/temp.nix
Refactor websites
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / temp.nix
index 288c8cc209461a320989bc0ce89f6cd031d0cff2..c24844e25f75d8d250f830b3927ea96fa927e61a 100644 (file)
@@ -1,24 +1,21 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   cfg = config.myServices.websites.immae.temp;
   varDir = "/var/lib/ftp/temp.immae.eu";
-  env = myconfig.env.websites.temp;
+  env = config.myEnv.websites.temp;
 in {
   options.myServices.websites.immae.temp.enable = lib.mkEnableOption "enable Temp' website";
 
   config = lib.mkIf cfg.enable {
     services.websites.env.production.modules = [ "headers" ];
-    services.websites.env.production.vhostConfs.temp = {
-      certName    = "eldiron";
+    services.websites.env.production.vhostConfs.immae_temp = {
+      certName    = "immae";
       addToCerts  = true;
       hosts       = [ "temp.immae.eu" ];
       root        = varDir;
       extraConfig = [
         ''
         Use Apaxy "${varDir}" "title .duplicity-ignore"
-        <FilesMatch ".+">
-          Header set Content-Disposition attachment
-        </FilesMatch>
         <Directory "${varDir}">
           Options -Indexes
           AllowOverride None