]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add first CHATONS properties page
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index 87bb848d7ddd044e578469158fa56890baa34b66..c63839e6cc43347eb42302af47e7ebf807f95522 100644 (file)
@@ -1,9 +1,11 @@
 { lib, pkgs, config,  ... }:
 let
   cfg = config.myServices.websites.immae.production;
-  varDir = "/var/lib/buildbot/outputs/immaeEu";
-  coursDir = "/var/lib/buildbot/outputs/cours";
-  rechercheDir = "/var/lib/buildbot/outputs/recherche";
+  varDir = "/var/lib/buildbot/outputs/immae/blog";
+  coursDir = "/var/lib/buildbot/outputs/immae/cours";
+  rechercheDir = "/var/lib/buildbot/outputs/immae/recherche";
+  recettesDir = "/var/lib/buildbot/outputs/immae/recettes";
+  historyDir = "/var/lib/buildbot/outputs/immae/history";
   env = config.myEnv.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
@@ -11,14 +13,28 @@ in {
   config = lib.mkIf cfg.enable {
     services.webstats.sites = [ { name = "www.immae.eu"; } ];
 
-    services.websites.env.production.vhostConfs.immae = {
-      certName    = "eldiron";
-      addToCerts  = true;
-      hosts       = [ "www.immae.eu" ];
-      root        = varDir;
-      extraConfig = [
+    services.websites.env.production.vhostConfs.immae_production = {
+      certName     = "immae";
+      addToCerts   = true;
+      certMainHost = "www.immae.eu";
+      hosts        = [ "www.immae.eu" "immae.eu" ];
+      root         = varDir;
+      extraConfig  = [
         ''
         Use Stats www.immae.eu
+        Header always set Strict-Transport-Security "max-age=31536000"
+
+        <LocationMatch /.well-known/(webfinger|host-meta)>
+          Header always set Referrer-Policy "strict-origin-when-cross-origin"
+          RequestHeader set X-Forwarded-Proto "https"
+
+          RewriteRule ^(.*)$ https://mastodon.immae.eu%{REQUEST_URI} [QSA,L]
+        </LocationMatch>
+
+        RewriteEngine On
+        RewriteCond "%{REQUEST_URI}" "!^/.well-known/(webfinger|host-meta)"
+        RewriteCond "%{HTTP_HOST}" "!^www\.immae\.eu$" [NC]
+        RewriteRule ^(.+)$ https://www.immae.eu$1 [R=302,L]
 
         <Directory ${varDir}>
           DirectoryIndex index.htm index.html
@@ -27,6 +43,13 @@ in {
           Require all granted
         </Directory>
 
+        Alias /.well-known/chatonsinfos ${./chatons}
+        <Directory ${./chatons}>
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride None
+          Require all granted
+        </Directory>
+
         Alias /cours ${coursDir}
         <Directory ${coursDir}>
           DirectoryIndex index.htm index.html
@@ -42,12 +65,27 @@ in {
           AllowOverride All
           Require all granted
         </Directory>
+
+        Alias /recettes ${recettesDir}
+        <Directory ${recettesDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
+        Alias /history ${historyDir}
+        <Directory ${historyDir}>
+          DirectoryIndex index.html
+          AllowOverride None
+          Require all granted
+        </Directory>
         ''
       ];
     };
 
-    services.websites.env.production.vhostConfs.immaeFr = {
-      certName    = "eldiron";
+    services.websites.env.production.vhostConfs.immae_fr = {
+      certName    = "immae";
       addToCerts  = true;
       hosts       = [ "www.immae.fr" "immae.fr" ];
       root        = null;
@@ -56,8 +94,8 @@ in {
         '' ];
     };
 
-    services.websites.env.production.vhostConfs.bouya = {
-      certName    = "eldiron";
+    services.websites.env.production.vhostConfs.immae_bouya = {
+      certName    = "immae";
       addToCerts  = true;
       hosts       = [ "bouya.org" "www.bouya.org" ];
       root        = null;