]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add first CHATONS properties page
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index 046246d584ee9f7a544367059a16763b5096a809..c63839e6cc43347eb42302af47e7ebf807f95522 100644 (file)
@@ -1,11 +1,11 @@
 { lib, pkgs, config,  ... }:
 let
   cfg = config.myServices.websites.immae.production;
-  varDir = "/var/lib/buildbot/outputs/immaeEu";
-  coursDir = "/var/lib/buildbot/outputs/cours";
-  rechercheDir = "/var/lib/buildbot/outputs/recherche";
-  recettesDir = "/var/lib/buildbot/outputs/recettes";
-  historyDir = pkgs.callPackage ./history {};
+  varDir = "/var/lib/buildbot/outputs/immae/blog";
+  coursDir = "/var/lib/buildbot/outputs/immae/cours";
+  rechercheDir = "/var/lib/buildbot/outputs/immae/recherche";
+  recettesDir = "/var/lib/buildbot/outputs/immae/recettes";
+  historyDir = "/var/lib/buildbot/outputs/immae/history";
   env = config.myEnv.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
@@ -43,6 +43,13 @@ in {
           Require all granted
         </Directory>
 
+        Alias /.well-known/chatonsinfos ${./chatons}
+        <Directory ${./chatons}>
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride None
+          Require all granted
+        </Directory>
+
         Alias /cours ${coursDir}
         <Directory ${coursDir}>
           DirectoryIndex index.htm index.html