]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Handle immae.fr from eldiron
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index e02d026fc2f91acba7ceabe50283479056270eba..87bb848d7ddd044e578469158fa56890baa34b66 100644 (file)
@@ -1,8 +1,10 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   cfg = config.myServices.websites.immae.production;
   varDir = "/var/lib/buildbot/outputs/immaeEu";
-  env = myconfig.env.websites.immae;
+  coursDir = "/var/lib/buildbot/outputs/cours";
+  rechercheDir = "/var/lib/buildbot/outputs/recherche";
+  env = config.myEnv.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
 
@@ -19,7 +21,23 @@ in {
         Use Stats www.immae.eu
 
         <Directory ${varDir}>
-          DirectoryIndex index.php index.htm index.html
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
+        Alias /cours ${coursDir}
+        <Directory ${coursDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
+        Alias /recherche ${rechercheDir}
+        <Directory ${rechercheDir}>
+          DirectoryIndex index.htm index.html
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted
@@ -28,6 +46,16 @@ in {
       ];
     };
 
+    services.websites.env.production.vhostConfs.immaeFr = {
+      certName    = "eldiron";
+      addToCerts  = true;
+      hosts       = [ "www.immae.fr" "immae.fr" ];
+      root        = null;
+      extraConfig = [ ''
+        RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://www.immae.eu/chapeaux/
+        '' ];
+    };
+
     services.websites.env.production.vhostConfs.bouya = {
       certName    = "eldiron";
       addToCerts  = true;