]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Use local website for research
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index bb110defc68648b79717cb63d95185e812a25286..439b455171f3b9bae2bdb95fc21306e8f52943f4 100644 (file)
@@ -1,10 +1,10 @@
 { lib, pkgs, config,  ... }:
 let
   cfg = config.myServices.websites.immae.production;
-  varDir = "/var/lib/buildbot/outputs/immaeEu";
-  coursDir = "/var/lib/buildbot/outputs/cours";
-  rechercheDir = "/var/lib/buildbot/outputs/recherche";
-  recettesDir = "/var/lib/buildbot/outputs/recettes";
+  varDir = "/var/lib/buildbot/outputs/immae/blog";
+  coursDir = "/var/lib/buildbot/outputs/immae/cours";
+  rechercheDir = "/var/lib/buildbot/outputs/immae/recherche";
+  recettesDir = "/var/lib/buildbot/outputs/immae/recettes";
   historyDir = "/var/lib/buildbot/outputs/immae/history";
   env = config.myEnv.websites.immae;
 in {
@@ -43,6 +43,13 @@ in {
           Require all granted
         </Directory>
 
+        Alias /.well-known/chatonsinfos ${./chatons}
+        <Directory ${./chatons}>
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride None
+          Require all granted
+        </Directory>
+
         Alias /cours ${coursDir}
         <Directory ${coursDir}>
           DirectoryIndex index.htm index.html
@@ -51,6 +58,14 @@ in {
           Require all granted
         </Directory>
 
+        Alias /eurl ${./eurl}
+        <Directory ${./eurl}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride None
+          Require all granted
+        </Directory>
+
         Alias /recherche ${rechercheDir}
         <Directory ${rechercheDir}>
           DirectoryIndex index.htm index.html
@@ -91,9 +106,14 @@ in {
       certName    = "immae";
       addToCerts  = true;
       hosts       = [ "bouya.org" "www.bouya.org" ];
-      root        = null;
+      root        = rechercheDir;
       extraConfig = [ ''
-        RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://www.normalesup.org/~bouya/
+        <Directory ${rechercheDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
         '' ];
     };
   };