]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add cours to buildbot
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index e02d026fc2f91acba7ceabe50283479056270eba..3b2301a8fd452c93cd89e08d99e84fe1686ab386 100644 (file)
@@ -2,6 +2,8 @@
 let
   cfg = config.myServices.websites.immae.production;
   varDir = "/var/lib/buildbot/outputs/immaeEu";
+  coursDir = "/var/lib/buildbot/outputs/cours";
+  rechercheDir = "/var/lib/buildbot/outputs/recherche";
   env = myconfig.env.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
@@ -19,7 +21,23 @@ in {
         Use Stats www.immae.eu
 
         <Directory ${varDir}>
-          DirectoryIndex index.php index.htm index.html
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
+        Alias /cours ${coursDir}
+        <Directory ${coursDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
+        Alias /recherche ${rechercheDir}
+        <Directory ${rechercheDir}>
+          DirectoryIndex index.htm index.html
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted