]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add cours to buildbot
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index 3c851e68a37ccc9e7b9cba4f034b911484507515..3b2301a8fd452c93cd89e08d99e84fe1686ab386 100644 (file)
@@ -1,7 +1,9 @@
 { lib, pkgs, config, myconfig,  ... }:
 let
   cfg = config.myServices.websites.immae.production;
-  varDir = "/var/lib/ftp/immae";
+  varDir = "/var/lib/buildbot/outputs/immaeEu";
+  coursDir = "/var/lib/buildbot/outputs/cours";
+  rechercheDir = "/var/lib/buildbot/outputs/recherche";
   env = myconfig.env.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
@@ -9,20 +11,6 @@ in {
   config = lib.mkIf cfg.enable {
     services.webstats.sites = [ { name = "www.immae.eu"; } ];
 
-    services.phpfpm.poolConfigs.immae = ''
-      listen = /run/phpfpm/immae.sock
-      user = wwwrun
-      group = wwwrun
-      listen.owner = wwwrun
-      listen.group = wwwrun
-
-      pm = ondemand
-      pm.max_children = 5
-      pm.process_idle_timeout = 60
-
-      php_admin_value[open_basedir] = "${varDir}:/tmp"
-      '';
-    services.websites.env.production.modules = [ "proxy_fcgi" ];
     services.websites.env.production.vhostConfs.immae = {
       certName    = "eldiron";
       addToCerts  = true;
@@ -32,21 +20,28 @@ in {
         ''
         Use Stats www.immae.eu
 
-        <FilesMatch "\.php$">
-          SetHandler "proxy:unix:/run/phpfpm/immae.sock|fcgi://localhost"
-        </FilesMatch>
-
         <Directory ${varDir}>
-          DirectoryIndex index.php index.htm index.html
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
+        Alias /cours ${coursDir}
+        <Directory ${coursDir}>
+          DirectoryIndex index.htm index.html
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted
         </Directory>
 
-        <Location /blog_old/>
-          Use LDAPConnect
-          Require ldap-group cn=blog,cn=immae.eu,ou=services,dc=immae,dc=eu
-        </Location>
+        Alias /recherche ${rechercheDir}
+        <Directory ${rechercheDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
         ''
       ];
     };