]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index 6b88ff2c0a1fbe28ce249c363f03a5836b7cf60e..12d6ddb413eb8d61b4fb869dfc8b4f0b26e16159 100644 (file)
@@ -1,8 +1,10 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   cfg = config.myServices.websites.immae.production;
-  varDir = "/var/lib/ftp/immae";
-  env = myconfig.env.websites.immae;
+  varDir = "/var/lib/buildbot/outputs/immaeEu";
+  coursDir = "/var/lib/buildbot/outputs/cours";
+  rechercheDir = "/var/lib/buildbot/outputs/recherche";
+  env = config.myEnv.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
 
@@ -19,16 +21,27 @@ in {
         Use Stats www.immae.eu
 
         <Directory ${varDir}>
-          DirectoryIndex index.php index.htm index.html
+          DirectoryIndex index.htm index.html
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted
         </Directory>
 
-        <Location /blog_old/>
-          Use LDAPConnect
-          Require ldap-group cn=blog,cn=immae.eu,ou=services,dc=immae,dc=eu
-        </Location>
+        Alias /cours ${coursDir}
+        <Directory ${coursDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
+        Alias /recherche ${rechercheDir}
+        <Directory ${rechercheDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
         ''
       ];
     };