]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add recettes website
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index 3d76b8611c77dd3626bd5aee4fe8c3a2c118b725..dff105363b77923fe215fef58160af7f7793066c 100644 (file)
@@ -4,6 +4,7 @@ let
   varDir = "/var/lib/buildbot/outputs/immaeEu";
   coursDir = "/var/lib/buildbot/outputs/cours";
   rechercheDir = "/var/lib/buildbot/outputs/recherche";
+  recettesDir = "/var/lib/buildbot/outputs/recettes";
   env = config.myEnv.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
@@ -55,6 +56,14 @@ in {
           AllowOverride All
           Require all granted
         </Directory>
+
+        Alias /recettes ${recettesDir}
+        <Directory ${recettesDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
         ''
       ];
     };