]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add documentation website
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index ff9cf9df3910f5558d450f3f95ce0baf84ea0f60..8b4998f39c42df7de04fed3539e33cce495433cb 100644 (file)
@@ -6,6 +6,7 @@ let
   rechercheDir = "/var/lib/buildbot/outputs/immae/recherche";
   recettesDir = "/var/lib/buildbot/outputs/immae/recettes";
   historyDir = "/var/lib/buildbot/outputs/immae/history";
+  docsDir = "/var/lib/buildbot/outputs/immae/docs/";
   env = config.myEnv.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
@@ -66,6 +67,14 @@ in {
           Require all granted
         </Directory>
 
+        Alias /docs ${docsDir}
+        <Directory ${docsDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
         Alias /eurl ${./eurl}
         <Directory ${./eurl}>
           DirectoryIndex index.htm index.html