]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/florian/production.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / florian / production.nix
index 1abc7158641041c55be7b2e189898c639798a81c..16c6022888357c61f8ce4e9936c2aa148c9b4bd5 100644 (file)
@@ -1,6 +1,6 @@
 { lib, pkgs, config,  ... }:
 let
-    adminer = pkgs.callPackage ../commons/adminer.nix {};
+    adminer = pkgs.callPackage ../commons/adminer.nix { inherit config; };
     cfg = config.myServices.websites.florian.production;
     varDir = "/var/lib/ftp/florian";
     env = config.myEnv.websites.florian;
@@ -8,7 +8,7 @@ in {
   options.myServices.websites.florian.production.enable = lib.mkEnableOption "enable Florian's website production";
 
   config = lib.mkIf cfg.enable {
-    security.acme2.certs."ftp".extraDomains."tellesflorian.com" = null;
+    security.acme.certs."ftp".extraDomains."tellesflorian.com" = null;
 
     services.websites.env.production.modules = adminer.apache.modules;
     services.websites.env.production.vhostConfs.florian = {
@@ -17,7 +17,7 @@ in {
       hosts        = [ "tellesflorian.com" "www.tellesflorian.com" ];
       root         = "${varDir}/tellesflorian.com";
       extraConfig  = [
-        adminer.apache.vhostConf
+        (adminer.apache.vhostConf null)
         ''
         ServerAdmin ${env.server_admin}