]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/florian/app.nix
Add integration certificate
[perso/Immae/Config/Nix.git] / modules / private / websites / florian / app.nix
index 7e2c33390faf5eb2834947d2b2c5952e067ad068..e262c5997d3a2b5a90f615a2db6ab0883862e7f2 100644 (file)
@@ -1,7 +1,7 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   adminer = pkgs.callPackage ../commons/adminer.nix {};
-  secrets = myconfig.env.websites.tellesflorian.integration;
+  secrets = config.myEnv.websites.tellesflorian.integration;
   app = pkgs.webapps.tellesflorian.override { environment = secrets.environment; };
   cfg = config.myServices.websites.florian.app;
   pcfg = config.services.phpApplication;
@@ -9,7 +9,7 @@ in {
   options.myServices.websites.florian.app.enable = lib.mkEnableOption "enable Florian's app in integration";
 
   config = lib.mkIf cfg.enable {
-    services.backup.profiles.tellesflorian_dev.rootDir = app.varDir;
+    services.duplyBackup.profiles.tellesflorian_dev.rootDir = app.varDir;
     services.phpApplication.apps.florian_dev = {
       websiteEnv = "integration";
       httpdUser = config.services.httpd.Inte.user;
@@ -58,7 +58,7 @@ in {
           parameters:
             database_host: ${secrets.mysql.host}
             database_port: ${secrets.mysql.port}
-            database_name: ${secrets.mysql.name}
+            database_name: ${secrets.mysql.database}
             database_user: ${secrets.mysql.user}
             database_password: ${secrets.mysql.password}
             mailer_transport: smtp
@@ -72,7 +72,7 @@ in {
 
     services.websites.env.integration.modules = adminer.apache.modules;
     services.websites.env.integration.vhostConfs.florian_dev = {
-      certName     = "eldiron";
+      certName     = "integration";
       addToCerts  = true;
       hosts       = [ "app.tellesflorian.com" ];
       root        = pcfg.webappDirs.florian_dev;