]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/florian/app.nix
Refactor websites
[perso/Immae/Config/Nix.git] / modules / private / websites / florian / app.nix
index c65c26f12d16a7836db13af5e8f15534b706a4ac..19a88b0d377b0786f1054120c7ffaf72bff39655 100644 (file)
@@ -2,15 +2,19 @@
 let
   adminer = pkgs.callPackage ../commons/adminer.nix { inherit config; };
   secrets = config.myEnv.websites.tellesflorian.integration;
-  app = pkgs.webapps.tellesflorian.override { environment = secrets.environment; };
+  app = pkgs.callPackage ./app {
+    environment = secrets.environment;
+    varDir = "/var/lib/florian_app";
+    secretsPath = config.secrets.fullPaths."websites/florian/app";
+  };
   cfg = config.myServices.websites.florian.app;
   pcfg = config.services.phpApplication;
 in {
   options.myServices.websites.florian.app.enable = lib.mkEnableOption "enable Florian's app in integration";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.tellesflorian_dev.rootDir = app.varDir;
-    services.phpApplication.apps.florian_dev = {
+    services.duplyBackup.profiles.florian_app.rootDir = app.varDir;
+    services.phpApplication.apps.florian_app = {
       websiteEnv = "integration";
       httpdUser = config.services.httpd.Inte.user;
       httpdGroup = config.services.httpd.Inte.group;
@@ -33,16 +37,16 @@ in {
         "pm.process_idle_timeout" = "60";
       };
       phpEnv = {
-        SYMFONY_DEBUG_MODE = "yes";
+        SYMFONY_DEBUG_MODE = "\"yes\"";
       };
       phpWatchFiles = [
-        config.secrets.fullPaths."webapps/${app.environment}-tellesflorian"
+        config.secrets.fullPaths."websites/florian/app"
       ];
     };
 
     secrets.keys = [
       {
-        dest = "webapps/${app.environment}-tellesflorian-passwords";
+        dest = "websites/florian/app_passwords";
         user = config.services.httpd.Inte.user;
         group = config.services.httpd.Inte.group;
         permissions = "0400";
@@ -51,7 +55,7 @@ in {
         '';
       }
       {
-        dest = "webapps/${app.environment}-tellesflorian";
+        dest = "websites/florian/app";
         user = config.services.httpd.Inte.user;
         group = config.services.httpd.Inte.group;
         permissions = "0400";
@@ -73,15 +77,15 @@ in {
     ];
 
     services.websites.env.integration.modules = adminer.apache.modules;
-    services.websites.env.integration.vhostConfs.florian_dev = {
-      certName     = "integration";
+    services.websites.env.integration.vhostConfs.florian_app = {
+      certName    = "integration";
       addToCerts  = true;
       hosts       = [ "app.tellesflorian.com" ];
-      root        = pcfg.webappDirs.florian_dev;
+      root        = pcfg.webappDirs.florian_app;
       extraConfig = [
         ''
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.florian_dev}|fcgi://localhost"
+          SetHandler "proxy:unix:${pcfg.phpListenPaths.florian_app}|fcgi://localhost"
         </FilesMatch>
 
         <Location />
@@ -89,13 +93,13 @@ in {
           Use LDAPConnect
           Require ldap-group   cn=app.tellesflorian.com,cn=httpd,ou=services,dc=immae,dc=eu
 
-          AuthUserFile "${config.secrets.fullPaths."webapps/${app.environment}-tellesflorian-passwords"}"
+          AuthUserFile "${config.secrets.fullPaths."websites/florian/app_passwords"}"
           Require user "invite"
 
           ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://tellesflorian.com\"></html>"
         </Location>
 
-        <Directory ${pcfg.webappDirs.florian_dev}>
+        <Directory ${pcfg.webappDirs.florian_app}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride None
           Require all granted