]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/florian/app.nix
Move devtools to other place
[perso/Immae/Config/Nix.git] / modules / private / websites / florian / app.nix
index 5e6255cabcc262603e65ee0ef472b54a1dce4988..27810a59e8de9726e39d8c6dada1e9106186c7fb 100644 (file)
@@ -2,12 +2,7 @@
 let
   adminer = pkgs.callPackage ../commons/adminer.nix { inherit config; };
   secrets = config.myEnv.websites.tellesflorian.integration;
-  app = pkgs.callPackage ./app {
-    composerEnv = pkgs.composerEnv.override { php = pkgs.php72; };
-    environment = secrets.environment;
-    varDir = "/var/lib/florian_app";
-    secretsPath = config.secrets.fullPaths."websites/florian/app";
-  };
+  webRoot = "/var/lib/ftp/immae/florian/web";
   cfg = config.myServices.websites.florian.app;
   pcfg = config.services.phpApplication;
 in {
@@ -19,14 +14,15 @@ in {
       websiteEnv = "integration";
       httpdUser = config.services.httpd.Inte.user;
       httpdGroup = config.services.httpd.Inte.group;
-      inherit (app) webRoot varDir;
+      inherit webRoot;
+      varDir = "/var/lib/ftp/immae/florian_var";
       varDirPaths = {
         "var" = "0700";
       };
-      inherit app;
+      app = "/var/lib/ftp/immae/florian";
       serviceDeps = [ "mysql.service" ];
       preStartActions = [
-        "./bin/console --env=${app.environment} cache:clear --no-warmup"
+        "./bin/console --env=dev cache:clear --no-warmup"
       ];
       phpOpenbasedir = [ "/tmp" ];
       phpPool = {
@@ -81,7 +77,7 @@ in {
       certName    = "integration";
       addToCerts  = true;
       hosts       = [ "app.tellesflorian.com" ];
-      root        = app.webRoot;
+      root        = webRoot;
       extraConfig = [
         ''
         <FilesMatch "\.php$">
@@ -99,7 +95,7 @@ in {
           ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://tellesflorian.com\"></html>"
         </Location>
 
-        <Directory ${app.webRoot}>
+        <Directory ${webRoot}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride None
           Require all granted