]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/denise/production.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / modules / private / websites / denise / production.nix
diff --git a/modules/private/websites/denise/production.nix b/modules/private/websites/denise/production.nix
deleted file mode 100644 (file)
index 9b28e9e..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-{ lib, config, pkgs, ... }:
-let
-  cfg = config.myServices.websites.denise.production;
-in {
-  options.myServices.websites.denise.production.enable = lib.mkEnableOption "enable Denise's website";
-
-  config = lib.mkIf cfg.enable {
-    services.websites.env.production.vhostConfs.denise_production = {
-      certName     = "denise";
-      addToCerts   = true;
-      hosts        = [ "syanni.eu" "www.syanni.eu" ];
-      root         = ../_www;
-      extraConfig  = [
-        ''
-        <Directory ${../_www}>
-          DirectoryIndex index.htm index.html
-          Options Indexes FollowSymLinks MultiViews Includes
-          AllowOverride AuthConfig
-          Require all granted
-        </Directory>
-          ''
-      ];
-    };
-  };
-}