]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Add status engine website
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index 186a15517db5b28599d71b059d015c8d1e919c92..f84567e8c8cf85c3b6519537e8f603daceb6a328 100644 (file)
@@ -100,24 +100,6 @@ in
     users.users.wwwrun.extraGroups = [ "keys" ];
     networking.firewall.allowedTCPPorts = [ 80 443 ];
 
-    nixpkgs.overlays = [ (self: super: rec {
-      php72 = (super.php72.override {
-        config.php.mysqlnd = true;
-        config.php.mysqli = false;
-        config.php.mhash = true; # Is it needed?
-      }).overrideAttrs(old: rec {
-        # Didn't manage to build with mysqli + mysql_config connector
-        configureFlags = old.configureFlags ++ [
-          "--with-mysqli=shared,mysqlnd"
-          ];
-        # preConfigure = (old.preConfigure or "") + ''
-        #   export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
-        #   sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
-        #     ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
-        #   '';
-      });
-    }) ];
-
     secrets.keys = [{
       dest = "apache-ldap";
       user = "wwwrun";
@@ -238,6 +220,10 @@ in
         production.enable = true;
       };
 
+      cip-ca = {
+        sympa.enable = true;
+      };
+
       connexionswing = {
         integration.enable = true;
         production.enable = true;
@@ -246,6 +232,8 @@ in
       denise = {
         evariste.enable = true;
         denisejerome.enable = true;
+        oms.enable = true;
+        production.enable = true;
       };
 
       emilia.moodle.enable = true;
@@ -298,6 +286,7 @@ in
       telio_tortay.production.enable = true;
 
       tools.cloud.enable = true;
+      tools.commento.enable = true;
       tools.dav.enable = true;
       tools.db.enable = true;
       tools.diaspora.enable = true;
@@ -306,6 +295,7 @@ in
       tools.mastodon.enable = true;
       tools.mediagoblin.enable = true;
       tools.peertube.enable = true;
+      tools.performance.enable = true;
       tools.tools.enable = true;
       tools.email.enable = true;