]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Add Telio Tortay website
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index c3d941c2f5014b3867e12e54fe806aaff6883f90..f55f7e3e120331b8869141c6b0da22a3ab464f08 100644 (file)
@@ -56,7 +56,7 @@ let
     };
     customLog = {
       extraConfig = ''
-        LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
+        LogFormat "%{Host}i:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
       '';
     };
   };
@@ -142,7 +142,7 @@ in
     services.filesWatcher.httpdInte.paths = [ "/var/secrets/apache-ldap" ];
     services.filesWatcher.httpdTools.paths = [ "/var/secrets/apache-ldap" ];
 
-    services.websites.production = {
+    services.websites.env.production = {
       enable = true;
       adminAddr = "httpd@immae.eu";
       httpdName = "Prod";
@@ -159,7 +159,7 @@ in
       };
     };
 
-    services.websites.integration = {
+    services.websites.env.integration = {
       enable = true;
       adminAddr = "httpd@immae.eu";
       httpdName = "Inte";
@@ -176,7 +176,7 @@ in
       };
     };
 
-    services.websites.tools = {
+    services.websites.env.tools = {
       enable = true;
       adminAddr = "httpd@immae.eu";
       httpdName = "Tools";
@@ -248,6 +248,7 @@ in
       nassime.production.enable = true;
 
       naturaloutil.production.enable = true;
+      telioTortay.production.enable = true;
 
       papa.surveillance.enable = true;
 
@@ -264,6 +265,7 @@ in
       tools.mediagoblin.enable = true;
       tools.peertube.enable = true;
       tools.tools.enable = true;
+      tools.email.enable = true;
     };
   };
 }