]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Update Chloé’s website
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index 3ac4cb548153f2af390c612d34572be381b728e4..aba30e37f73c2606c7c828ea90676e8fc8a31a7a 100644 (file)
@@ -43,7 +43,21 @@ let
       '';
     };
     global = {
-      extraConfig = (pkgs.webapps.apache-default.override { inherit www_root;}).apacheConfig;
+      extraConfig = ''
+        ErrorDocument 500 /maintenance_immae.html
+        ErrorDocument 501 /maintenance_immae.html
+        ErrorDocument 502 /maintenance_immae.html
+        ErrorDocument 503 /maintenance_immae.html
+        ErrorDocument 504 /maintenance_immae.html
+        Alias /maintenance_immae.html ${www_root}/maintenance_immae.html
+        ProxyPass /maintenance_immae.html !
+
+        AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${www_root}/googleb6d69446ff4ca3e5.html
+        <Directory ${www_root}>
+          AllowOverride None
+          Require all granted
+        </Directory>
+      '';
     };
     apaxy = {
       extraConfig = (pkgs.webapps.apache-theme.override { inherit theme_root; }).apacheConfig;
@@ -64,17 +78,7 @@ let
   makeExtraConfig = (builtins.filter (x: x != null) (lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) apacheConfig));
 in
 {
-  options.myServices.websites = {
-    enable = lib.mkEnableOption "enable websites";
-
-    webappDirs = lib.mkOption {
-      type = lib.types.attrsOf lib.types.path;
-      description = ''
-        Webapp paths to create in /run/current-system/webapps
-        '';
-      default = {};
-    };
-  };
+  options.myServices.websites.enable = lib.mkEnableOption "enable websites";
 
   config = lib.mkIf config.myServices.websites.enable {
     services.duplyBackup.profiles.php = {
@@ -87,9 +91,9 @@ in
       #openssl = self.openssl_1_1;
       php = php72;
       php72 = (super.php72.override {
-        mysql.connector-c = self.mariadb;
-        config.php.mysqlnd = false;
+        config.php.mysqlnd = true;
         config.php.mysqli = false;
+        config.php.mhash = true; # Is it needed?
       }).overrideAttrs(old: rec {
         # Didn't manage to build with mysqli + mysql_config connector
         configureFlags = old.configureFlags ++ [
@@ -125,7 +129,7 @@ in
 
     system.activationScripts = {
       httpd = ''
-        install -d -m 0755 ${config.security.acme.directory}/acme-challenge
+        install -d -m 0755 /var/lib/acme/acme-challenges
         install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
         '';
     };
@@ -140,9 +144,9 @@ in
         ; 30 days (minutes)
         session.cache_expire = 43200
         '';
-      extraConfig = ''
-        log_level = notice
-        '';
+      settings = {
+        log_level = "notice";
+      };
     };
 
     services.filesWatcher.httpdProd.paths = [ "/var/secrets/apache-ldap" ];
@@ -213,55 +217,76 @@ in
       };
     };
 
-    system.extraSystemBuilderCmds = lib.mkIf (builtins.length (builtins.attrValues config.myServices.websites.webappDirs) > 0) ''
-    mkdir -p $out/webapps
-    ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (name: path: "ln -s ${path} $out/webapps/${name}") config.myServices.websites.webappDirs)}
-    '';
-
+    services.websites.webappDirs = {
+      _www = ./_www;
+      _theme = pkgs.webapps.apache-theme.theme;
+    };
     myServices.websites = {
-      webappDirs = {
-        _www = pkgs.webapps.apache-default.www;
-        _theme = pkgs.webapps.apache-theme.theme;
-      };
+      capitaines.landing_pages.enable = true;
 
-      aten.integration.enable = true;
-      aten.production.enable = true;
+      chloe = {
+        integration.enable = true;
+        production.enable = true;
+      };
 
-      capitaines.production.enable = true;
+      connexionswing = {
+        integration.enable = true;
+        production.enable = true;
+      };
 
-      chloe.integration.enable = true;
-      chloe.production.enable = true;
+      denise = {
+        evariste.enable = true;
+        denisejerome.enable = true;
+      };
 
-      connexionswing.integration.enable = true;
-      connexionswing.production.enable = true;
+      emilia.moodle.enable = true;
 
-      denisejerome.production.enable = true;
+      florian = {
+        app.enable = true;
+        integration.enable = true;
+        production.enable = true;
+      };
 
-      emilia.production.enable = true;
-      emilia.richie_production.enable = true;
+      immae = {
+        production.enable = true;
+        release.enable = true;
+        temp.enable = true;
+      };
 
-      florian.app.enable = true;
-      florian.integration.enable = true;
-      florian.production.enable = true;
+      isabelle = {
+        aten_integration.enable = true;
+        aten_production.enable = true;
+        iridologie.enable = true;
+      };
 
-      immae.production.enable = true;
-      immae.release.enable = true;
-      immae.temp.enable = true;
+      jerome.naturaloutil.enable = true;
 
       leila.production.enable = true;
 
-      ludivinecassal.integration.enable = true;
-      ludivinecassal.production.enable = true;
+      ludivine = {
+        integration.enable = true;
+        production.enable = true;
+      };
 
       nassime.production.enable = true;
 
-      naturaloutil.production.enable = true;
-      telioTortay.production.enable = true;
+      nathanael.villon.enable = true;
 
-      papa.surveillance.enable = true;
+      papa = {
+        surveillance.enable = true;
+        maison_bbc.enable = true;
+      };
+
+      piedsjaloux = {
+        integration.enable = true;
+        production.enable = true;
+      };
 
-      piedsjaloux.integration.enable = true;
-      piedsjaloux.production.enable = true;
+      richie.production.enable = true;
+
+      syden.peertube.enable = true;
+
+      telio_tortay.production.enable = true;
 
       tools.cloud.enable = true;
       tools.dav.enable = true;
@@ -274,6 +299,8 @@ in
       tools.peertube.enable = true;
       tools.tools.enable = true;
       tools.email.enable = true;
+
+      games.codenames.enable = true;
     };
   };
 }