]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Add Patrick Fodella’s website
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index 864d5d90e2f800f7a09b5a5a615266e22908ede4..90a8c1a837da6b91d69a5f2d49828b0c8d4dc616 100644 (file)
@@ -89,6 +89,14 @@ let
   };
   makeModules = lib.lists.flatten (lib.attrsets.mapAttrsToList (n: v: v.modules or []) apacheConfig);
   makeExtraConfig = (builtins.filter (x: x != null) (lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) apacheConfig));
+  moomin = let
+    lines = lib.splitString "\n" (lib.fileContents ./moomin.txt);
+    pad = width: str: let
+        padWidth = width - lib.stringLength str;
+        padding = lib.concatStrings (lib.genList (lib.const "0") padWidth);
+      in lib.optionalString (padWidth > 0) padding + str;
+  in
+    lib.imap0 (i: e: ''Header always set "X-Moomin-${pad 2 (builtins.toString i)}" "${e}"'') lines;
 in
 {
   options.myServices.websites.enable = lib.mkEnableOption "enable websites";
@@ -96,6 +104,7 @@ in
   config = lib.mkIf config.myServices.websites.enable {
     services.duplyBackup.profiles.php = {
       rootDir = "/var/lib/php";
+      remotes = [ "eriomem" "ovh" ];
     };
     users.users.wwwrun.extraGroups = [ "keys" ];
     networking.firewall.allowedTCPPorts = [ 80 443 ];
@@ -169,7 +178,7 @@ in
         let ips = config.myEnv.servers.eldiron.ips.integration;
         in [ips.ip4] ++ (ips.ip6 or []);
       modules = makeModules;
-      extraConfig = makeExtraConfig;
+      extraConfig = makeExtraConfig ++ moomin;
       fallbackVhost = {
         certName    = "eldiron";
         hosts       = ["eldiron.immae.eu" ];
@@ -233,6 +242,7 @@ in
         evariste.enable = true;
         denisejerome.enable = true;
         oms.enable = true;
+        aventuriers.enable = true;
         production.enable = true;
       };
 
@@ -274,6 +284,8 @@ in
         maison_bbc.enable = true;
       };
 
+      patrick_fodella.production.enable = true;
+
       piedsjaloux = {
         integration.enable = true;
         production.enable = true;
@@ -285,6 +297,7 @@ in
 
       telio_tortay.production.enable = true;
 
+      tools.assets.enable = true;
       tools.cloud.enable = true;
       tools.commento.enable = true;
       tools.dav.enable = true;
@@ -295,6 +308,7 @@ in
       tools.mastodon.enable = true;
       tools.mediagoblin.enable = true;
       tools.peertube.enable = true;
+      tools.performance.enable = true;
       tools.tools.enable = true;
       tools.email.enable = true;