]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Implement mta-sts and move mail services to specific domain
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index 8b02977c98ff8111e300ae446463be7cead4b37b..63dd53d234bec5bb264967967578669cd6b2c3fa 100644 (file)
@@ -56,7 +56,7 @@ let
     };
     customLog = {
       extraConfig = ''
-        LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
+        LogFormat "%{Host}i:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
       '';
     };
   };
@@ -138,7 +138,11 @@ in
         '';
     };
 
-    services.websites.production = {
+    services.filesWatcher.httpdProd.paths = [ "/var/secrets/apache-ldap" ];
+    services.filesWatcher.httpdInte.paths = [ "/var/secrets/apache-ldap" ];
+    services.filesWatcher.httpdTools.paths = [ "/var/secrets/apache-ldap" ];
+
+    services.websites.env.production = {
       enable = true;
       adminAddr = "httpd@immae.eu";
       httpdName = "Prod";
@@ -155,7 +159,7 @@ in
       };
     };
 
-    services.websites.integration = {
+    services.websites.env.integration = {
       enable = true;
       adminAddr = "httpd@immae.eu";
       httpdName = "Inte";
@@ -172,7 +176,7 @@ in
       };
     };
 
-    services.websites.tools = {
+    services.websites.env.tools = {
       enable = true;
       adminAddr = "httpd@immae.eu";
       httpdName = "Tools";
@@ -260,6 +264,7 @@ in
       tools.mediagoblin.enable = true;
       tools.peertube.enable = true;
       tools.tools.enable = true;
+      tools.email.enable = true;
     };
   };
 }