]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index 5c0e65540e639039e4f8eed3ac7a2277a2966ea3..529ec5ced31226e0bfeb6966efab0f42f5c3c07f 100644 (file)
@@ -87,9 +87,9 @@ in
       #openssl = self.openssl_1_1;
       php = php72;
       php72 = (super.php72.override {
-        mysql.connector-c = self.mariadb;
-        config.php.mysqlnd = false;
+        config.php.mysqlnd = true;
         config.php.mysqli = false;
+        config.php.mhash = true; # Is it needed?
       }).overrideAttrs(old: rec {
         # Didn't manage to build with mysqli + mysql_config connector
         configureFlags = old.configureFlags ++ [
@@ -140,9 +140,9 @@ in
         ; 30 days (minutes)
         session.cache_expire = 43200
         '';
-      extraConfig = ''
-        log_level = notice
-        '';
+      settings = {
+        log_level = "notice";
+      };
     };
 
     services.filesWatcher.httpdProd.paths = [ "/var/secrets/apache-ldap" ];