]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/connexionswing/production.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / websites / connexionswing / production.nix
index 79e672a254a891dc672b729793656d74807deed6..fa31931eaa43418fad5f73b679357434b29c44f0 100644 (file)
@@ -1,6 +1,6 @@
-{ lib, pkgs, config,  myconfig, ... }:
+{ lib, pkgs, config,  ... }:
 let
-  secrets = myconfig.env.websites.connexionswing.production;
+  secrets = config.myEnv.websites.connexionswing.production;
   app = pkgs.webapps.connexionswing.override { environment = secrets.environment; };
   cfg = config.myServices.websites.connexionswing.production;
   pcfg = config.services.phpApplication;
@@ -8,7 +8,7 @@ in {
   options.myServices.websites.connexionswing.production.enable = lib.mkEnableOption "enable Connexionswing's website in production";
 
   config = lib.mkIf cfg.enable {
-    services.backup.profiles.connexionswing_prod.rootDir = app.varDir;
+    services.duplyBackup.profiles.connexionswing_prod.rootDir = app.varDir;
     services.webstats.sites = [ { name = "connexionswing.com"; } ];
     services.phpApplication.apps.connexionswing_prod = {
       websiteEnv = "production";
@@ -52,7 +52,7 @@ in {
           parameters:
               database_host: ${secrets.mysql.host}
               database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.name}
+              database_name: ${secrets.mysql.database}
               database_user: ${secrets.mysql.user}
               database_password: ${secrets.mysql.password}
               database_server_version: ${pkgs.mariadb.mysqlVersion}