]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/connexionswing/production.nix
Use attrs for secrets instead of lists
[perso/Immae/Config/Nix.git] / modules / private / websites / connexionswing / production.nix
index 0b52af1771418e2816355808cf6f40b9e0a02acb..981e95e45312dbb3dc5143b753eea48288706442 100644 (file)
@@ -1,16 +1,22 @@
 { lib, pkgs, config,  ... }:
 let
   secrets = config.myEnv.websites.connexionswing.production;
-  app = pkgs.webapps.connexionswing.override { environment = secrets.environment; };
+  app = pkgs.callPackage ./app {
+    composerEnv = pkgs.composerEnv.override { php = pkgs.php72; };
+    environment = secrets.environment;
+    varDir = "/var/lib/connexionswing_production";
+    secretsPath = config.secrets.fullPaths."websites/connexionswing/production";
+  };
   cfg = config.myServices.websites.connexionswing.production;
   pcfg = config.services.phpApplication;
 in {
   options.myServices.websites.connexionswing.production.enable = lib.mkEnableOption "enable Connexionswing's website in production";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.connexionswing_prod.rootDir = app.varDir;
+    services.duplyBackup.profiles.connexionswing_production.rootDir = app.varDir;
+    services.duplyBackup.profiles.connexionswing_production.remotes = ["eriomem" "ovh"];
     services.webstats.sites = [ { name = "connexionswing.com"; } ];
-    services.phpApplication.apps.connexionswing_prod = {
+    services.phpApplication.apps.connexionswing_production = {
       websiteEnv = "production";
       httpdUser = config.services.httpd.Prod.user;
       httpdGroup = config.services.httpd.Prod.group;
@@ -37,49 +43,47 @@ in {
         "pm.max_spare_servers" = "3";
       };
       phpWatchFiles = [
-        config.secrets.fullPaths."webapps/${app.environment}-connexionswing"
+        config.secrets.fullPaths."websites/connexionswing/production"
       ];
+      phpPackage = pkgs.php72;
     };
 
-    secrets.keys = [
-      {
-        dest = "webapps/${app.environment}-connexionswing";
-        user = config.services.httpd.Prod.user;
-        group = config.services.httpd.Prod.group;
-        permissions = "0400";
-        text = ''
-          # This file is auto-generated during the composer install
-          parameters:
-              database_host: ${secrets.mysql.host}
-              database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.database}
-              database_user: ${secrets.mysql.user}
-              database_password: ${secrets.mysql.password}
-              database_server_version: ${pkgs.mariadb.mysqlVersion}
-              mailer_transport: sendmail
-              mailer_host: null
-              mailer_user: null
-              mailer_password: null
-              subscription_email: ${secrets.email}
-              allow_robots: true
-              secret: ${secrets.secret}
-          services:
-            swiftmailer.mailer.default.transport:
-                class:     Swift_SendmailTransport
-                arguments: ['/run/wrappers/bin/sendmail -bs']
-        '';
-      }
-    ];
+    secrets.keys."websites/connexionswing/production" = {
+      user = config.services.httpd.Prod.user;
+      group = config.services.httpd.Prod.group;
+      permissions = "0400";
+      text = ''
+        # This file is auto-generated during the composer install
+        parameters:
+            database_host: ${secrets.mysql.host}
+            database_port: ${secrets.mysql.port}
+            database_name: ${secrets.mysql.database}
+            database_user: ${secrets.mysql.user}
+            database_password: ${secrets.mysql.password}
+            database_server_version: ${pkgs.mariadb.mysqlVersion}
+            mailer_transport: sendmail
+            mailer_host: null
+            mailer_user: null
+            mailer_password: null
+            subscription_email: ${secrets.email}
+            allow_robots: true
+            secret: ${secrets.secret}
+        services:
+          swiftmailer.mailer.default.transport:
+              class:     Swift_SendmailTransport
+              arguments: ['/run/wrappers/bin/sendmail -bs']
+      '';
+    };
 
-    services.websites.env.production.vhostConfs.connexionswing_prod = {
+    services.websites.env.production.vhostConfs.connexionswing_production = {
       certName     = "connexionswing";
       certMainHost = "connexionswing.com";
       hosts        = ["connexionswing.com" "sandetludo.com" "www.connexionswing.com" "www.sandetludo.com" ];
-      root         = pcfg.webappDirs.connexionswing_prod;
+      root         = pcfg.webappDirs.connexionswing_production;
       extraConfig  = [
         ''
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.connexionswing_prod}|fcgi://localhost"
+          SetHandler "proxy:unix:${pcfg.phpListenPaths.connexionswing_production}|fcgi://localhost"
         </FilesMatch>
 
         <Directory ${app.varDir}/medias>
@@ -96,7 +100,7 @@ in {
 
         Use Stats connexionswing.com
 
-        <Directory ${pcfg.webappDirs.connexionswing_prod}>
+        <Directory ${pcfg.webappDirs.connexionswing_production}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted