]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/connexionswing/production.nix
Remove webappdirs
[perso/Immae/Config/Nix.git] / modules / private / websites / connexionswing / production.nix
index 45991ac7725783fb9a80441185e7196b5272ce79..144093aeef9719edd132e2bf074dffe43b1925a2 100644 (file)
@@ -13,7 +13,8 @@ in {
   options.myServices.websites.connexionswing.production.enable = lib.mkEnableOption "enable Connexionswing's website in production";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.connexionswing_produdction.rootDir = app.varDir;
+    services.duplyBackup.profiles.connexionswing_production.rootDir = app.varDir;
+    services.duplyBackup.profiles.connexionswing_production.remotes = ["eriomem" "ovh"];
     services.webstats.sites = [ { name = "connexionswing.com"; } ];
     services.phpApplication.apps.connexionswing_production = {
       websiteEnv = "production";
@@ -47,41 +48,38 @@ in {
       phpPackage = pkgs.php72;
     };
 
-    secrets.keys = [
-      {
-        dest = "websites/connexionswing/production";
-        user = config.services.httpd.Prod.user;
-        group = config.services.httpd.Prod.group;
-        permissions = "0400";
-        text = ''
-          # This file is auto-generated during the composer install
-          parameters:
-              database_host: ${secrets.mysql.host}
-              database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.database}
-              database_user: ${secrets.mysql.user}
-              database_password: ${secrets.mysql.password}
-              database_server_version: ${pkgs.mariadb.mysqlVersion}
-              mailer_transport: sendmail
-              mailer_host: null
-              mailer_user: null
-              mailer_password: null
-              subscription_email: ${secrets.email}
-              allow_robots: true
-              secret: ${secrets.secret}
-          services:
-            swiftmailer.mailer.default.transport:
-                class:     Swift_SendmailTransport
-                arguments: ['/run/wrappers/bin/sendmail -bs']
-        '';
-      }
-    ];
+    secrets.keys."websites/connexionswing/production" = {
+      user = config.services.httpd.Prod.user;
+      group = config.services.httpd.Prod.group;
+      permissions = "0400";
+      text = ''
+        # This file is auto-generated during the composer install
+        parameters:
+            database_host: ${secrets.mysql.host}
+            database_port: ${secrets.mysql.port}
+            database_name: ${secrets.mysql.database}
+            database_user: ${secrets.mysql.user}
+            database_password: ${secrets.mysql.password}
+            database_server_version: ${pkgs.mariadb.mysqlVersion}
+            mailer_transport: sendmail
+            mailer_host: null
+            mailer_user: null
+            mailer_password: null
+            subscription_email: ${secrets.email}
+            allow_robots: true
+            secret: ${secrets.secret}
+        services:
+          swiftmailer.mailer.default.transport:
+              class:     Swift_SendmailTransport
+              arguments: ['/run/wrappers/bin/sendmail -bs']
+      '';
+    };
 
     services.websites.env.production.vhostConfs.connexionswing_production = {
       certName     = "connexionswing";
       certMainHost = "connexionswing.com";
       hosts        = ["connexionswing.com" "sandetludo.com" "www.connexionswing.com" "www.sandetludo.com" ];
-      root         = pcfg.webappDirs.connexionswing_production;
+      root         = app.webRoot;
       extraConfig  = [
         ''
         <FilesMatch "\.php$">
@@ -102,7 +100,7 @@ in {
 
         Use Stats connexionswing.com
 
-        <Directory ${pcfg.webappDirs.connexionswing_production}>
+        <Directory ${app.webRoot}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted