]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/connexionswing/integration.nix
Move devtools to other place
[perso/Immae/Config/Nix.git] / modules / private / websites / connexionswing / integration.nix
index c0f7445ba68a2128d2cf6c9bacc918e8ad718a32..fe0e4d93c6a9e1396d369669caed4a0bdee7cac7 100644 (file)
@@ -1,88 +1,89 @@
 { lib, pkgs, config,  ... }:
 let
   secrets = config.myEnv.websites.connexionswing.integration;
-  app = pkgs.webapps.connexionswing.override { environment = secrets.environment; };
+  webRoot = "/var/lib/ftp/immae/connexionswing/web";
+  varDir = "/var/lib/ftp/immae/connexionswing_var";
   cfg = config.myServices.websites.connexionswing.integration;
   pcfg = config.services.phpApplication;
 in {
   options.myServices.websites.connexionswing.integration.enable = lib.mkEnableOption "enable Connexionswing's website in integration";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.connexionswing_dev.rootDir = app.varDir;
-    services.phpApplication.apps.connexionswing_dev = {
+    services.duplyBackup.profiles.connexionswing_integration.rootDir = app.varDir;
+    services.phpApplication.apps.connexionswing_integration = {
       websiteEnv = "integration";
       httpdUser = config.services.httpd.Inte.user;
       httpdGroup = config.services.httpd.Inte.group;
-      inherit (app) webRoot varDir;
+      inherit webRoot varDir;
       varDirPaths = {
         "medias" = "0700";
         "uploads" = "0700";
         "var" = "0700";
       };
-      inherit app;
+      app = "/var/lib/ftp/immae/connexionswing";
       serviceDeps = [ "mysql.service" ];
       preStartActions = [
-        "./bin/console --env=${app.environment} cache:clear --no-warmup"
+        "./bin/console --env=dev cache:clear --no-warmup"
       ];
       phpOpenbasedir = [ "/tmp" "/run/wrappers/bin/sendmail" ];
-      phpPool = ''
-        php_admin_value[upload_max_filesize] = 20M
-        php_admin_value[post_max_size] = 20M
-        ;php_admin_flag[log_errors] = on
-        pm = ondemand
-        pm.max_children = 5
-        pm.process_idle_timeout = 60
-        env[SYMFONY_DEBUG_MODE] = "yes"
-      '';
+      phpPool = {
+        "php_admin_value[upload_max_filesize]" = "20M";
+        "php_admin_value[post_max_size]" = "20M";
+        #"php_admin_flag[log_errors]" = "on";
+        "pm" = "ondemand";
+        "pm.max_children" = "5";
+        "pm.process_idle_timeout" = "60";
+        };
+      phpEnv = {
+        SYMFONY_DEBUG_MODE = "\"yes\"";
+      };
       phpWatchFiles = [
-        config.secrets.fullPaths."webapps/${app.environment}-connexionswing"
+        config.secrets.fullPaths."websites/connexionswing/integration"
       ];
+      phpPackage = pkgs.php72;
+    };
+
+    secrets.keys."websites/connexionswing/integration" = {
+      user = config.services.httpd.Inte.user;
+      group = config.services.httpd.Inte.group;
+      permissions = "0400";
+      text = ''
+        # This file is auto-generated during the composer install
+        parameters:
+            database_host: ${secrets.mysql.host}
+            database_port: ${secrets.mysql.port}
+            database_name: ${secrets.mysql.database}
+            database_user: ${secrets.mysql.user}
+            database_password: ${secrets.mysql.password}
+            database_server_version: ${pkgs.mariadb.mysqlVersion}
+            mailer_transport: sendmail
+            mailer_host: null
+            mailer_user: null
+            mailer_password: null
+            subscription_email: ${secrets.email}
+            allow_robots: true
+            secret: ${secrets.secret}
+      '';
     };
 
-    secrets.keys = [
-      {
-        dest = "webapps/${app.environment}-connexionswing";
-        user = config.services.httpd.Inte.user;
-        group = config.services.httpd.Inte.group;
-        permissions = "0400";
-        text = ''
-          # This file is auto-generated during the composer install
-          parameters:
-              database_host: ${secrets.mysql.host}
-              database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.database}
-              database_user: ${secrets.mysql.user}
-              database_password: ${secrets.mysql.password}
-              database_server_version: ${pkgs.mariadb.mysqlVersion}
-              mailer_transport: sendmail
-              mailer_host: null
-              mailer_user: null
-              mailer_password: null
-              subscription_email: ${secrets.email}
-              allow_robots: true
-              secret: ${secrets.secret}
-        '';
-      }
-    ];
-
-    services.websites.env.integration.vhostConfs.connexionswing_dev = {
-      certName     = "eldiron";
+    services.websites.env.integration.vhostConfs.connexionswing_integration = {
+      certName    = "integration";
       addToCerts  = true;
       hosts       = ["connexionswing.immae.eu" "sandetludo.immae.eu" ];
-      root        = pcfg.webappDirs.connexionswing_dev;
+      root        = webRoot;
       extraConfig = [
         ''
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.connexionswing_dev}|fcgi://localhost"
+          SetHandler "proxy:unix:${pcfg.phpListenPaths.connexionswing_integration}|fcgi://localhost"
         </FilesMatch>
 
-        <Directory ${app.varDir}/medias>
+        <Directory ${varDir}/medias>
           Options FollowSymLinks
           AllowOverride None
           Require all granted
         </Directory>
 
-        <Directory ${app.varDir}/uploads>
+        <Directory ${varDir}/uploads>
           Options FollowSymLinks
           AllowOverride None
           Require all granted
@@ -94,7 +95,7 @@ in {
           ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://connexionswing.com\"></html>"
         </Location>
 
-        <Directory ${pcfg.webappDirs.connexionswing_dev}>
+        <Directory ${webRoot}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride None
           Require all granted