]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/connexionswing/integration.nix
Remove overlay that overrides the php version
[perso/Immae/Config/Nix.git] / modules / private / websites / connexionswing / integration.nix
index 54dbf54f7b13db3c70e23696b467466984440359..f5b1a1602091b5cf2857218b6624c7807b36b35b 100644 (file)
@@ -1,15 +1,20 @@
-{ lib, pkgs, config,  myconfig, ... }:
+{ lib, pkgs, config,  ... }:
 let
-  secrets = myconfig.env.websites.connexionswing.integration;
-  app = pkgs.webapps.connexionswing.override { environment = secrets.environment; };
+  secrets = config.myEnv.websites.connexionswing.integration;
+  app = pkgs.callPackage ./app {
+    composerEnv = pkgs.composerEnv.override { php = pkgs.php72; };
+    environment = secrets.environment;
+    varDir = "/var/lib/connexionswing_integration";
+    secretsPath = config.secrets.fullPaths."websites/connexionswing/integration";
+  };
   cfg = config.myServices.websites.connexionswing.integration;
   pcfg = config.services.phpApplication;
 in {
   options.myServices.websites.connexionswing.integration.enable = lib.mkEnableOption "enable Connexionswing's website in integration";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.connexionswing_dev.rootDir = app.varDir;
-    services.phpApplication.apps.connexionswing_dev = {
+    services.duplyBackup.profiles.connexionswing_integration.rootDir = app.varDir;
+    services.phpApplication.apps.connexionswing_integration = {
       websiteEnv = "integration";
       httpdUser = config.services.httpd.Inte.user;
       httpdGroup = config.services.httpd.Inte.group;
@@ -25,23 +30,26 @@ in {
         "./bin/console --env=${app.environment} cache:clear --no-warmup"
       ];
       phpOpenbasedir = [ "/tmp" "/run/wrappers/bin/sendmail" ];
-      phpPool = ''
-        php_admin_value[upload_max_filesize] = 20M
-        php_admin_value[post_max_size] = 20M
-        ;php_admin_flag[log_errors] = on
-        pm = ondemand
-        pm.max_children = 5
-        pm.process_idle_timeout = 60
-        env[SYMFONY_DEBUG_MODE] = "yes"
-      '';
+      phpPool = {
+        "php_admin_value[upload_max_filesize]" = "20M";
+        "php_admin_value[post_max_size]" = "20M";
+        #"php_admin_flag[log_errors]" = "on";
+        "pm" = "ondemand";
+        "pm.max_children" = "5";
+        "pm.process_idle_timeout" = "60";
+        };
+      phpEnv = {
+        SYMFONY_DEBUG_MODE = "\"yes\"";
+      };
       phpWatchFiles = [
-        config.secrets.fullPaths."webapps/${app.environment}-connexionswing"
+        config.secrets.fullPaths."websites/connexionswing/integration"
       ];
+      phpPackage = pkgs.php72;
     };
 
     secrets.keys = [
       {
-        dest = "webapps/${app.environment}-connexionswing";
+        dest = "websites/connexionswing/integration";
         user = config.services.httpd.Inte.user;
         group = config.services.httpd.Inte.group;
         permissions = "0400";
@@ -50,7 +58,7 @@ in {
           parameters:
               database_host: ${secrets.mysql.host}
               database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.name}
+              database_name: ${secrets.mysql.database}
               database_user: ${secrets.mysql.user}
               database_password: ${secrets.mysql.password}
               database_server_version: ${pkgs.mariadb.mysqlVersion}
@@ -65,15 +73,15 @@ in {
       }
     ];
 
-    services.websites.env.integration.vhostConfs.connexionswing_dev = {
-      certName     = "eldiron";
+    services.websites.env.integration.vhostConfs.connexionswing_integration = {
+      certName    = "integration";
       addToCerts  = true;
       hosts       = ["connexionswing.immae.eu" "sandetludo.immae.eu" ];
-      root        = pcfg.webappDirs.connexionswing_dev;
+      root        = pcfg.webappDirs.connexionswing_integration;
       extraConfig = [
         ''
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.connexionswing_dev}|fcgi://localhost"
+          SetHandler "proxy:unix:${pcfg.phpListenPaths.connexionswing_integration}|fcgi://localhost"
         </FilesMatch>
 
         <Directory ${app.varDir}/medias>
@@ -94,7 +102,7 @@ in {
           ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://connexionswing.com\"></html>"
         </Location>
 
-        <Directory ${pcfg.webappDirs.connexionswing_dev}>
+        <Directory ${pcfg.webappDirs.connexionswing_integration}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride None
           Require all granted