]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/production.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / production.nix
index 578bf918cab22fecc52798a546560d1d731a3965..83f6c9b6a07720ffc9bb783c67d53e1603fc5065 100644 (file)
@@ -19,8 +19,9 @@ in {
     systemd.services.phpfpm-chloe_prod.after = lib.mkAfter chloe.phpFpm.serviceDeps;
     systemd.services.phpfpm-chloe_prod.wants = chloe.phpFpm.serviceDeps;
     services.phpfpm.pools.chloe_prod = {
-      listen = chloe.phpFpm.socket;
-      extraConfig = chloe.phpFpm.pool;
+      user = config.services.httpd.Prod.user;
+      group = config.services.httpd.Prod.group;
+      settings = chloe.phpFpm.pool;
       phpOptions = config.services.phpfpm.phpOptions + ''
         extension=${pkgs.php}/lib/php/extensions/mysqli.so
       '';
@@ -39,7 +40,7 @@ in {
           RewriteCond "%{HTTP_HOST}" "!^www\.osteopathe-cc\.fr$" [NC]
           RewriteRule ^(.+)$ https://www.osteopathe-cc.fr$1 [R=302,L]
           ''
-        chloe.apache.vhostConf
+        (chloe.apache.vhostConf config.services.phpfpm.pools.chloe_prod.socket)
       ];
     };
     services.websites.env.production.watchPaths = [