]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/production.nix
Refactor websites options
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / production.nix
index 6e0c34d7d8cb6789361ca10dcf65c78106380871..6cfdb7f381580a05196207f24c571ab25f71dd4f 100644 (file)
@@ -26,15 +26,15 @@ in {
     };
     system.activationScripts.chloe_prod = chloe.activationScript;
     myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
-    services.websites.production.modules = chloe.apache.modules;
-    services.websites.production.vhostConfs.chloe = {
+    services.websites.env.production.modules = chloe.apache.modules;
+    services.websites.env.production.vhostConfs.chloe = {
       certName     = "chloe";
       certMainHost = "osteopathe-cc.fr";
       hosts        = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ];
       root         = chloe.apache.root;
       extraConfig  = [ chloe.apache.vhostConf ];
     };
-    services.websites.production.watchPaths = [
+    services.websites.env.production.watchPaths = [
       "/var/secrets/webapps/${chloe.app.environment}-chloe"
     ];
   };