]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/production.nix
Rename backup module to duply_backup
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / production.nix
index 6e0c34d7d8cb6789361ca10dcf65c78106380871..0562de8d2f825f3fc6ea670aa4c4e444111d143f 100644 (file)
@@ -12,6 +12,7 @@ in {
   options.myServices.websites.chloe.production.enable = lib.mkEnableOption "enable Chloe's website in production";
 
   config = lib.mkIf cfg.enable {
+    services.duplyBackup.profiles.chloe_prod.rootDir = chloe.app.varDir;
     secrets.keys = chloe.keys;
     services.webstats.sites = [ { name = "osteopathe-cc.fr"; } ];
 
@@ -26,15 +27,15 @@ in {
     };
     system.activationScripts.chloe_prod = chloe.activationScript;
     myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
-    services.websites.production.modules = chloe.apache.modules;
-    services.websites.production.vhostConfs.chloe = {
+    services.websites.env.production.modules = chloe.apache.modules;
+    services.websites.env.production.vhostConfs.chloe = {
       certName     = "chloe";
       certMainHost = "osteopathe-cc.fr";
       hosts        = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ];
       root         = chloe.apache.root;
       extraConfig  = [ chloe.apache.vhostConf ];
     };
-    services.websites.production.watchPaths = [
+    services.websites.env.production.watchPaths = [
       "/var/secrets/webapps/${chloe.app.environment}-chloe"
     ];
   };