]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/integration.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / integration.nix
index 00c76a5b7ef5b961915228d8f998a52b391d30b6..caf6548dbb01a0ab4c48807cb2936e6ae25c6c82 100644 (file)
@@ -1,8 +1,8 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   chloe  = pkgs.callPackage ./builder.nix {
     inherit (pkgs.webapps) chloe;
-    config = myconfig.env.websites.chloe.integration;
+    config = config.myEnv.websites.chloe.integration;
     apacheUser = config.services.httpd.Inte.user;
     apacheGroup = config.services.httpd.Inte.group;
   };
@@ -17,8 +17,9 @@ in {
     systemd.services.phpfpm-chloe_dev.after = lib.mkAfter chloe.phpFpm.serviceDeps;
     systemd.services.phpfpm-chloe_dev.wants = chloe.phpFpm.serviceDeps;
     services.phpfpm.pools.chloe_dev = {
-      listen = chloe.phpFpm.socket;
-      extraConfig = chloe.phpFpm.pool;
+      user = config.services.httpd.Inte.user;
+      group = config.services.httpd.Inte.group;
+      settings = chloe.phpFpm.pool;
       phpOptions = config.services.phpfpm.phpOptions + ''
         extension=${pkgs.php}/lib/php/extensions/mysqli.so
       '';
@@ -27,11 +28,13 @@ in {
     myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
     services.websites.env.integration.modules = chloe.apache.modules;
     services.websites.env.integration.vhostConfs.chloe = {
-      certName    = "eldiron";
+      certName    = "integration";
       addToCerts  = true;
       hosts       = ["chloe.immae.eu" ];
       root        = chloe.apache.root;
-      extraConfig = [ chloe.apache.vhostConf ];
+      extraConfig = [
+        (chloe.apache.vhostConf config.services.phpfpm.pools.chloe_dev.socket)
+      ];
     };
     services.websites.env.integration.watchPaths = [
       "/var/secrets/webapps/${chloe.app.environment}-chloe"