]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/integration.nix
Add integration certificate
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / integration.nix
index d49a85c084cfc473528943630a3ae0f90602cae8..6276eb7bf1a236a8c51b37220505eab001440361 100644 (file)
@@ -1,8 +1,8 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   chloe  = pkgs.callPackage ./builder.nix {
     inherit (pkgs.webapps) chloe;
-    config = myconfig.env.websites.chloe.integration;
+    config = config.myEnv.websites.chloe.integration;
     apacheUser = config.services.httpd.Inte.user;
     apacheGroup = config.services.httpd.Inte.group;
   };
@@ -12,6 +12,7 @@ in {
   options.myServices.websites.chloe.integration.enable = lib.mkEnableOption "enable Chloe's website in integration";
 
   config = lib.mkIf cfg.enable {
+    services.duplyBackup.profiles.chloe_dev.rootDir = chloe.app.varDir;
     secrets.keys = chloe.keys;
     systemd.services.phpfpm-chloe_dev.after = lib.mkAfter chloe.phpFpm.serviceDeps;
     systemd.services.phpfpm-chloe_dev.wants = chloe.phpFpm.serviceDeps;
@@ -23,17 +24,17 @@ in {
       '';
     };
     system.activationScripts.chloe_dev = chloe.activationScript;
-    system.extraSystemBuilderCmds = ''
-      mkdir -p $out/webapps
-      ln -s ${chloe.app.webRoot} $out/webapps/${chloe.apache.webappName}
-      '';
-    services.websites.integration.modules = chloe.apache.modules;
-    services.websites.integration.vhostConfs.chloe = {
-      certName    = "eldiron";
+    myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
+    services.websites.env.integration.modules = chloe.apache.modules;
+    services.websites.env.integration.vhostConfs.chloe = {
+      certName    = "integration";
       addToCerts  = true;
       hosts       = ["chloe.immae.eu" ];
       root        = chloe.apache.root;
       extraConfig = [ chloe.apache.vhostConf ];
     };
+    services.websites.env.integration.watchPaths = [
+      "/var/secrets/webapps/${chloe.app.environment}-chloe"
+    ];
   };
 }