]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/integration.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / integration.nix
index c42a428250c6542d9a486f0d9aa4989b5859645f..273d1fcc3cd25c855b469419a748ba6462c6783a 100644 (file)
@@ -1,8 +1,8 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   chloe  = pkgs.callPackage ./builder.nix {
     inherit (pkgs.webapps) chloe;
-    config = myconfig.env.websites.chloe.integration;
+    config = config.myEnv.websites.chloe.integration;
     apacheUser = config.services.httpd.Inte.user;
     apacheGroup = config.services.httpd.Inte.group;
   };
@@ -12,6 +12,7 @@ in {
   options.myServices.websites.chloe.integration.enable = lib.mkEnableOption "enable Chloe's website in integration";
 
   config = lib.mkIf cfg.enable {
+    services.duplyBackup.profiles.chloe_dev.rootDir = chloe.app.varDir;
     secrets.keys = chloe.keys;
     systemd.services.phpfpm-chloe_dev.after = lib.mkAfter chloe.phpFpm.serviceDeps;
     systemd.services.phpfpm-chloe_dev.wants = chloe.phpFpm.serviceDeps;
@@ -24,13 +25,16 @@ in {
     };
     system.activationScripts.chloe_dev = chloe.activationScript;
     myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
-    services.websites.integration.modules = chloe.apache.modules;
-    services.websites.integration.vhostConfs.chloe = {
+    services.websites.env.integration.modules = chloe.apache.modules;
+    services.websites.env.integration.vhostConfs.chloe = {
       certName    = "eldiron";
       addToCerts  = true;
       hosts       = ["chloe.immae.eu" ];
       root        = chloe.apache.root;
       extraConfig = [ chloe.apache.vhostConf ];
     };
+    services.websites.env.integration.watchPaths = [
+      "/var/secrets/webapps/${chloe.app.environment}-chloe"
+    ];
   };
 }