]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/integration.nix
Add a filesWatcher service to restart them when secrets change
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / integration.nix
index d49a85c084cfc473528943630a3ae0f90602cae8..25ec4db3a3d95e86cac1408b516134a7b69fa058 100644 (file)
@@ -23,10 +23,7 @@ in {
       '';
     };
     system.activationScripts.chloe_dev = chloe.activationScript;
-    system.extraSystemBuilderCmds = ''
-      mkdir -p $out/webapps
-      ln -s ${chloe.app.webRoot} $out/webapps/${chloe.apache.webappName}
-      '';
+    myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
     services.websites.integration.modules = chloe.apache.modules;
     services.websites.integration.vhostConfs.chloe = {
       certName    = "eldiron";
@@ -35,5 +32,8 @@ in {
       root        = chloe.apache.root;
       extraConfig = [ chloe.apache.vhostConf ];
     };
+    services.websites.integration.watchPaths = [
+      "/var/secrets/webapps/${chloe.app.environment}-chloe"
+    ];
   };
 }