]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/integration.nix
Refactor websites options
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / integration.nix
index 25ec4db3a3d95e86cac1408b516134a7b69fa058..1f7ac3121e7dc84013e8d1bfffe1fcc8bc078ea0 100644 (file)
@@ -24,15 +24,15 @@ in {
     };
     system.activationScripts.chloe_dev = chloe.activationScript;
     myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
-    services.websites.integration.modules = chloe.apache.modules;
-    services.websites.integration.vhostConfs.chloe = {
+    services.websites.env.integration.modules = chloe.apache.modules;
+    services.websites.env.integration.vhostConfs.chloe = {
       certName    = "eldiron";
       addToCerts  = true;
       hosts       = ["chloe.immae.eu" ];
       root        = chloe.apache.root;
       extraConfig = [ chloe.apache.vhostConf ];
     };
-    services.websites.integration.watchPaths = [
+    services.websites.env.integration.watchPaths = [
       "/var/secrets/webapps/${chloe.app.environment}-chloe"
     ];
   };