]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/integration.nix
Remove webappdirs
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / integration.nix
index c4b79f87b737e8ef2db1f9251a8a169bf0d7ee10..7ed385255baa958ad1a202e7e26e9ce1aef265ff 100644 (file)
@@ -9,7 +9,6 @@ let
     varDir = "/var/lib/chloe_integration";
   };
   cfg = config.myServices.websites.chloe.integration;
-  webappdir = config.services.websites.webappDirsPaths.chloe_integration;
 in {
   options.myServices.websites.chloe.integration.enable = lib.mkEnableOption "enable Chloe's website in integration";
 
@@ -61,13 +60,12 @@ in {
         install -m 0750 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir}/phpSessions
       '';
     };
-    services.websites.webappDirs.chloe_integration = app.webRoot;
     services.websites.env.integration.modules = [ "proxy_fcgi" ];
     services.websites.env.integration.vhostConfs.chloe_integration = {
       certName    = "integration";
       addToCerts  = true;
       hosts       = ["chloe.immae.eu" ];
-      root        = webappdir;
+      root        = app.webRoot;
       extraConfig = [
       ''
         Include ${config.secrets.fullPaths."websites/chloe/integration"}
@@ -78,16 +76,16 @@ in {
           SetHandler "proxy:unix:${config.services.phpfpm.pools.chloe_integration.socket}|fcgi://localhost"
         </FilesMatch>
 
-        <Directory ${webappdir}>
+        <Directory ${app.webRoot}>
           DirectoryIndex index.php index.htm index.html
           Options -Indexes +FollowSymLinks +MultiViews +Includes
-          Include ${webappdir}/htaccess.txt
+          Include ${app.webRoot}/htaccess.txt
 
           AllowOverride AuthConfig FileInfo Limit
           Require all granted
         </Directory>
 
-        <DirectoryMatch "${webappdir}/squelettes">
+        <DirectoryMatch "${app.webRoot}/squelettes">
           Require all denied
         </DirectoryMatch>