]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/aten/integration.nix
Finish moving aten php configuration to dedicated module
[perso/Immae/Config/Nix.git] / modules / private / websites / aten / integration.nix
index 0dbc4fa91495aedb835b05caec2eb09b287e3ed7..38068a7708f375332456e9b48a7c12162144f7c7 100644 (file)
@@ -1,43 +1,83 @@
 { lib, pkgs, config, myconfig,  ... }:
 let
-  aten = pkgs.callPackage ./builder.nix {
-    inherit (pkgs.webapps) aten;
-    config = myconfig.env.websites.aten.integration;
-    apacheUser = config.services.httpd.Inte.user;
-    apacheGroup = config.services.httpd.Inte.group;
-  };
-
+  secrets = myconfig.env.websites.aten.integration;
+  app = pkgs.webapps.aten.override { environment = secrets.environment; };
   cfg = config.myServices.websites.aten.integration;
+  pcfg = config.services.phpApplication;
 in {
   options.myServices.websites.aten.integration.enable = lib.mkEnableOption "enable Aten's website in integration";
 
   config = lib.mkIf cfg.enable {
-    services.phpApplication.aten_dev = let
-      app = pkgs.webapps.aten.override { environment = "dev"; };
-    in {
+    services.phpApplication.apps.aten_dev = {
       websiteEnv = "integration";
       httpdUser = config.services.httpd.Inte.user;
       httpdGroup = config.services.httpd.Inte.group;
+      httpdWatchFiles = [
+        config.secrets.fullPaths."webapps/${app.environment}-aten"
+      ];
       inherit (app) webRoot varDir;
       inherit app;
       serviceDeps = [ "postgresql.service" ];
       preStartActions = [
         "APP_ENV=${app.environment} ./bin/console --env=${app.environment} cache:clear --no-warmup"
       ];
-      watchFiles = [
-        "${config.secrets.location}/webapps/${app.environment}-aten"
-      ];
-      webappName = "aten_dev";
+      phpOpenbasedir = [ "/tmp" ];
+      phpPool = ''
+        php_admin_value[upload_max_filesize] = 20M
+        php_admin_value[post_max_size] = 20M
+        ;php_admin_flag[log_errors] = on
+        pm = ondemand
+        pm.max_children = 5
+        pm.process_idle_timeout = 60
+        env[SYMFONY_DEBUG_MODE] = "yes"
+      '';
     };
 
-    secrets.keys = aten.keys;
-    services.phpfpm.poolConfigs.aten_dev = aten.phpFpm.pool;
-    services.websites.env.integration.vhostConfs.aten = {
+    secrets.keys = [{
+      dest = "webapps/${app.environment}-aten";
+      user = config.services.httpd.Inte.user;
+      group = config.services.httpd.Inte.user;
+      permissions = "0400";
+      text = ''
+        SetEnv APP_ENV      "${app.environment}"
+        SetEnv APP_SECRET   "${secrets.secret}"
+        SetEnv DATABASE_URL "${secrets.psql_url}"
+        '';
+    }];
+    services.websites.env.integration.vhostConfs.aten_dev = {
       certName    = "eldiron";
       addToCerts  = true;
       hosts       = [ "dev.aten.pro" ];
-      root        = aten.apache.root;
-      extraConfig = [ aten.apache.vhostConf ];
+      root        = pcfg.webappDirs.aten_dev;
+      extraConfig = [
+        ''
+        <FilesMatch "\.php$">
+          SetHandler "proxy:unix:${pcfg.phpListenPaths.aten_dev}|fcgi://localhost"
+        </FilesMatch>
+
+        Include ${config.secrets.fullPaths."webapps/${app.environment}-aten"}
+
+        <Location />
+          Use LDAPConnect
+          Require ldap-group   cn=dev.aten.pro,cn=httpd,ou=services,dc=immae,dc=eu
+          ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://aten.pro\"></html>"
+        </Location>
+
+        <Location /backend>
+          Use LDAPConnect
+          Require ldap-group   cn=dev.aten.pro,cn=httpd,ou=services,dc=immae,dc=eu
+          ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://aten.pro\"></html>"
+        </Location>
+
+        <Directory ${pcfg.webappDirs.aten_dev}>
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+          DirectoryIndex index.php
+          FallbackResource /index.php
+        </Directory>
+        ''
+      ];
     };
   };
 }