]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/monitoring-1.nix
Update stateVersion
[perso/Immae/Config/Nix.git] / modules / private / system / monitoring-1.nix
index 14604780e51e50356882333815fa395991b791a0..7581c01e523afaff07c0f0162f6126480c2fe15d 100644 (file)
@@ -3,7 +3,6 @@
 {
   boot.kernelPackages = pkgs.linuxPackages_latest;
   myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
-  hostEnv.FQDN = "monitoring-1.v.immae.eu";
 
   imports = builtins.attrValues (import ../..);
 
     firewall.enable = true;
     interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
       (n: ips: { address = ips.ip4; prefixLength = 32; })
-      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.myEnv.servers.monitoring-1.ips);
+      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips);
     interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
       (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
-      config.myEnv.servers.monitoring-1.ips);
+      config.hostEnv.ips);
     defaultGateway6 = { address = "fe80::1"; interface = "ens3"; };
   };
   myServices.mailRelay.enable = true;
@@ -37,5 +36,5 @@
   # database servers. You should change this only after NixOS release
   # notes say you should.
   # https://nixos.org/nixos/manual/release-notes.html
-  system.stateVersion = "19.03"; # Did you read the comment?
+  system.stateVersion = "20.03"; # Did you read the comment?
 }