]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/eldiron.nix
Change cron e-mail
[perso/Immae/Config/Nix.git] / modules / private / system / eldiron.nix
index b71df33d41020e1d5ab6cf1ccae77b764e00a918..bf4cefb14cf9a291530274caed746843d4aa89e5 100644 (file)
@@ -3,6 +3,7 @@
 {
   boot.kernelPackages = pkgs.linuxPackages_latest;
   _module.args.privateFiles = privateFiles;
+  _module.args.hostFQDN = "eldiron.immae.eu";
 
   networking = {
     firewall.enable = true;
 
   imports = builtins.attrValues (import ../..);
 
+  boot.kernel.sysctl = {
+    # https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001.md
+    "net.ipv4.tcp_sack" = 0;
+  };
   myServices.buildbot.enable = true;
   myServices.databases.enable = true;
   myServices.gitolite.enable = true;
+  myServices.monitoring.enable = true;
   myServices.irc.enable = true;
   myServices.pub.enable = true;
   myServices.tasks.enable = true;
+  myServices.mpd.enable = true;
+  myServices.dns.enable = true;
+  myServices.certificates.enable = true;
+  myServices.websites.enable = true;
+  myServices.mail.enable = true;
   services.pure-ftpd.enable = true;
+  services.duplyBackup.enable = true;
 
   deployment = {
     targetEnv = "hetzner";
@@ -47,6 +59,7 @@
 
   services.cron = {
     enable = true;
+    mailto = "cron@immae.eu";
     systemCronJobs = [
       ''
         # The star after /var/lib/* avoids deleting all folders in case of problem
@@ -59,5 +72,6 @@
   # to be compatible, in order to avoid breaking some software such as
   # database servers. You should change this only after NixOS release
   # notes say you should.
-  system.stateVersion = "18.09"; # Did you read the comment?
+  # https://nixos.org/nixos/manual/release-notes.html
+  system.stateVersion = "19.03"; # Did you read the comment?
 }