]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/dilion.nix
Migrate caldance configuration to nixos
[perso/Immae/Config/Nix.git] / modules / private / system / dilion.nix
index 379117c740025efdb8bedc3ac1982716182eef85..a0d56cc355769d77d69db14c642aca714c893803 100644 (file)
@@ -1,5 +1,5 @@
 { privateFiles }:
-{ config, pkgs, name, ... }:
+{ config, pkgs, name, lib, ... }:
 {
   boot.supportedFilesystems = [ "zfs" ];
   boot.kernelPackages = pkgs.linuxPackages_latest;
@@ -41,6 +41,8 @@
     };
   };
 
+  system.nssModules = [ pkgs.libvirt ];
+  system.nssHosts = lib.mkForce [ "files" "libvirt_guest" "mymachines" "dns" "myhostname" ];
   programs.zsh.enable = true;
 
   users.users.backup = {
     install -m 0750 -o backup -g root -d /var/lib/backup/eldiron
   '';
 
+  system.activationScripts.libvirtd_exports = ''
+    install -m 0755 -o root -g root -d /var/lib/caldance
+  '';
   virtualisation.docker.enable = true;
   virtualisation.libvirtd.enable = true;
   users.extraUsers.immae.extraGroups = [ "libvirtd" "docker" ];
   systemd.services.libvirtd.postStart = ''
     install -m 0770 -g libvirtd -d /var/lib/libvirt/images
   '';
+  systemd.services.socat-caldance = {
+    description = "Forward ssh port to caldance";
+    wantedBy = [ "multi-user.target" ];
+    after = [ "network.target" ];
+
+    serviceConfig = {
+      ExecStart = "${pkgs.socat}/bin/socat TCP-LISTEN:8022,fork TCP:nixops-99a7e1ba-54dc-11ea-a965-10bf487fe63b-caldance:22";
+    };
+  };
 
   time.timeZone = "Europe/Paris";
   nix = {
       "discourse.immae.eu" = null;
       "discourse.cip-ca.fr" = null;
       "dev.immae.eu" = null;
+      "caldance.immae.eu" = null;
     };
   };
   services.nginx = {
     recommendedOptimisation = true;
     recommendedGzipSettings = true;
     recommendedProxySettings = true;
+    upstreams = {
+      caldance.servers."nixops-99a7e1ba-54dc-11ea-a965-10bf487fe63b-caldance:3031" = {};
+    };
     virtualHosts = {
       "dev.immae.eu" = {
         acmeRoot = config.myServices.certificates.webroot;
         forceSSL = true;
         locations."/".proxyPass = "http://localhost:18031";
       };
+      "caldance.immae.eu" = {
+        acmeRoot = config.myServices.certificates.webroot;
+        useACMEHost = name;
+        forceSSL = true;
+        locations."/".extraConfig = ''
+          uwsgi_pass caldance;
+        '';
+        locations."/static/".alias = "/var/lib/caldance/caldance/app/www/static/";
+        locations."/media/".alias = "/var/lib/caldance/caldance/media/";
+        extraConfig = ''
+          auth_basic           "Authentification requise";
+          auth_basic_user_file ${pkgs.writeText "htpasswd" config.myEnv.websites.caldance.integration.password};
+        '';
+      };
     };
   };