]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/dilion.nix
Remove discourse
[perso/Immae/Config/Nix.git] / modules / private / system / dilion.nix
index 911c76d6c002a23dc09591efa47cf1849be974d5..5c246565eba94d5f93efd233550df4eaad331d98 100644 (file)
@@ -1,10 +1,25 @@
 { privateFiles }:
-{ config, pkgs, ... }:
+{ config, pkgs, name, lib, ... }:
 {
+  boot.supportedFilesystems = [ "zfs" ];
   boot.kernelPackages = pkgs.linuxPackages_latest;
   myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
 
+  fileSystems = {
+    "/"           = lib.mkForce { fsType = "zfs"; device = "zpool/root"; };
+    "/boot"       = { fsType = "ext4"; device = "/dev/disk/by-uuid/fd1c511e-2bc0-49d5-b8bb-95e7e8c8c816"; };
+    "/etc"        = { fsType = "zfs"; device = "zpool/root/etc"; };
+    "/home"       = { fsType = "zfs"; device = "zpool/root/home"; };
+    "/home/immae" = { fsType = "zfs"; device = "zpool/root/home/immae"; };
+    "/tmp"        = { fsType = "zfs"; device = "zpool/root/tmp"; };
+    "/var"        = { fsType = "zfs"; device = "zpool/root/var"; };
+  };
+  boot.initrd.secrets = {
+    "/boot/pass.key" = "/boot/pass.key";
+  };
+
   networking = {
+    hostId = "27c3048d"; # generated with head -c4 /dev/urandom | od -A none -t x4
     firewall.enable = false;
     interfaces."eth0".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
       (n: ips: { address = ips.ip4; prefixLength = 32; })
     };
   };
 
+  system.nssModules = [ pkgs.libvirt ];
+  system.nssDatabases.hosts = lib.mkForce [ "files" "libvirt_guest" "mymachines" "dns" "myhostname" ];
   programs.zsh.enable = true;
 
   users.users.backup = {
-    home = "/var/lib/backup";
-    createHome = true;
     hashedPassword = "!";
     isSystemUser = true;
+    extraGroups = [ "keys" ];
     shell = pkgs.bashInteractive;
     openssh.authorizedKeys.keys = let
+      zreplConfig = config.secrets.fullPaths."zrepl/zrepl.yml";
     in
-      ["command=\"${pkgs.rrsync_sudo}/bin/rrsync /var/lib/backup/eldiron/\"  ${config.myEnv.rsync_backup.ssh_key.public}"];
+      ["command=\"${pkgs.zrepl}/bin/zrepl stdinserver --config ${zreplConfig} eldiron\",restrict ${config.myEnv.zrepl_backup.ssh_key.public}"];
   };
   security.sudo.extraRules = pkgs.lib.mkAfter [
-    {
-      commands = [
-        { command = "${pkgs.rsync}/bin/rsync"; options = [ "NOPASSWD" ]; }
-      ];
-      users = [ "backup" ];
-      runAs = "root";
-    }
     {
       commands = [
         { command = "/home/immae/.nix-profile/root_scripts/*"; options = [ "NOPASSWD" ]; }
   ];
 
   boot.kernel.sysctl."vm.nr_hugepages" = 256; # for xmr-stak
-  system.activationScripts.backup_home = ''
-    chown root:root /var/lib/backup
-    install -m 0750 -o backup -g root -d /var/lib/backup/eldiron
+  system.activationScripts.libvirtd_exports = ''
+    install -m 0755 -o root -g root -d /var/lib/caldance
   '';
-
   virtualisation.docker.enable = true;
+  virtualisation.docker.storageDriver = "zfs";
   virtualisation.libvirtd.enable = true;
   users.extraUsers.immae.extraGroups = [ "libvirtd" "docker" ];
   systemd.services.libvirtd.postStart = ''
     install -m 0770 -g libvirtd -d /var/lib/libvirt/images
   '';
+  systemd.services.socat-caldance = {
+    description = "Forward ssh port to caldance";
+    wantedBy = [ "multi-user.target" ];
+    after = [ "network.target" ];
+
+    serviceConfig = {
+      ExecStart = "${pkgs.socat}/bin/socat TCP-LISTEN:8022,fork TCP:nixops-99a7e1ba-54dc-11ea-a965-10bf487fe63b-caldance:22";
+    };
+  };
 
   time.timeZone = "Europe/Paris";
   nix = {
 
   # This is equivalent to setting environment.sessionVariables.NIX_PATH
   nix.nixPath = [
-    "home-manager=https://github.com/rycee/home-manager/archive/master.tar.gz"
-    "nixpkgs=https://nixos.org/channels/nixos-unstable/nixexprs.tar.xz"
+    "home-manager=${pkgs.sources.home-manager.url}"
+    "nixpkgs=${pkgs.sources.nixpkgs-home-manager.url}"
   ];
   nix.binaryCaches = [ "https://hydra.iohk.io" "https://cache.nixos.org" ];
   nix.binaryCachePublicKeys = [ "hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ=" ];
 
+  myServices.certificates.enable = true;
+  security.acme.certs."${name}" = {
+    user = config.services.nginx.user;
+    group = config.services.nginx.group;
+    extraDomains = {
+      "dev.immae.eu" = null;
+      "caldance.immae.eu" = null;
+    };
+  };
+  services.nginx = {
+    enable = true;
+    recommendedOptimisation = true;
+    recommendedGzipSettings = true;
+    recommendedProxySettings = true;
+    upstreams = {
+      caldance.servers."nixops-99a7e1ba-54dc-11ea-a965-10bf487fe63b-caldance:3031" = {};
+    };
+    virtualHosts = {
+      "dev.immae.eu" = {
+        acmeRoot = config.myServices.certificates.webroot;
+        useACMEHost = name;
+        forceSSL = true;
+        root = "/home/immae/www";
+      };
+      "caldance.immae.eu" = {
+        acmeRoot = config.myServices.certificates.webroot;
+        useACMEHost = name;
+        forceSSL = true;
+        locations."/".extraConfig = ''
+          uwsgi_pass caldance;
+        '';
+        locations."/static/".alias = "/var/lib/caldance/caldance/app/www/static/";
+        locations."/media/".alias = "/var/lib/caldance/caldance/media/";
+        extraConfig = ''
+          auth_basic           "Authentification requise";
+          auth_basic_user_file ${pkgs.writeText "htpasswd" config.myEnv.websites.caldance.integration.password};
+        '';
+      };
+    };
+  };
+
+  systemd.services.zrepl.serviceConfig.RuntimeDirectory = lib.mkForce "zrepl zrepl/stdinserver";
+  systemd.services.zrepl.serviceConfig.User = "backup";
+  # zfs allow backup create,mount,receive,destroy,rename,snapshot,hold,bookmark,release zpool/backup
+  services.zrepl = {
+    enable = true;
+    config = ''
+      global:
+        control:
+          sockpath: /run/zrepl/control
+        serve:
+          stdinserver:
+            sockdir: /run/zrepl/stdinserver
+      jobs:
+        - type: sink
+          # must not change
+          name: "backup-from-eldiron"
+          root_fs: "zpool/backup"
+          serve:
+            type: stdinserver
+            client_identities:
+              - eldiron
+    '';
+  };
   # This value determines the NixOS release with which your system is
   # to be compatible, in order to avoid breaking some software such as
   # database servers. You should change this only after NixOS release
   # notes say you should.
   # https://nixos.org/nixos/manual/release-notes.html
-  system.stateVersion = "19.03"; # Did you read the comment?
+  system.stateVersion = "20.03"; # Did you read the comment?
 }