]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/dilion.nix
Upgrade environment and freeze home-manager/nixpkgs version
[perso/Immae/Config/Nix.git] / modules / private / system / dilion.nix
index d8bad6b72ed9632bf633bd63734d4a3b25db7dce..379117c740025efdb8bedc3ac1982716182eef85 100644 (file)
@@ -1,10 +1,12 @@
 { privateFiles }:
 { config, pkgs, name, ... }:
 {
+  boot.supportedFilesystems = [ "zfs" ];
   boot.kernelPackages = pkgs.linuxPackages_latest;
   myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
 
   networking = {
+    hostId = "27c3048d"; # generated with head -c4 /dev/urandom | od -A none -t x4
     firewall.enable = false;
     interfaces."eth0".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
       (n: ips: { address = ips.ip4; prefixLength = 32; })
 
   # This is equivalent to setting environment.sessionVariables.NIX_PATH
   nix.nixPath = [
-    "home-manager=https://github.com/rycee/home-manager/archive/master.tar.gz"
-    "nixpkgs=https://nixos.org/channels/nixos-unstable/nixexprs.tar.xz"
+    "home-manager=${pkgs.sources.home-manager.url}"
+    "nixpkgs=${pkgs.sources.nixpkgs-home-manager.url}"
   ];
   nix.binaryCaches = [ "https://hydra.iohk.io" "https://cache.nixos.org" ];
   nix.binaryCachePublicKeys = [ "hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ=" ];
     extraDomains = {
       "discourse.immae.eu" = null;
       "discourse.cip-ca.fr" = null;
+      "dev.immae.eu" = null;
     };
   };
   services.nginx = {
     recommendedGzipSettings = true;
     recommendedProxySettings = true;
     virtualHosts = {
+      "dev.immae.eu" = {
+        acmeRoot = config.myServices.certificates.webroot;
+        useACMEHost = name;
+        forceSSL = true;
+        root = "/home/immae/www";
+      };
       "discourse.immae.eu" = {
         acmeRoot = config.myServices.certificates.webroot;
         useACMEHost = name;